Note: There are a few cases of duplicates in user autocompletion which are being worked on.
Bug 398073 (operationfx)

Setup of new www.operationfirefox.com website

VERIFIED FIXED

Status

Websites
Other
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Andrew Stein, Assigned: fligtar)

Tracking

Details

(Whiteboard: [qa-p3], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 

Operation Firefox is the new marketing contest set to begin shortly that has participants placing giants Fathead stickers with the Firefox logo all over the country and the world.

The www.operationfirefox.com website will have 6-7 pages and should work in Firefox mainly, but also IE, Safari and Opera.  There will be a home page, submit page (where contestants will enter their idea submissions), a blog page, FAQ page, and rules page.  There will later be a second version of the submit page after the deadline has passed.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
--> IT, as this bug has nothing to do with www.mozilla.com.

So, you're not actually requesting anything be done in this bug. Mozilla already owns operationfirefox.com, so that's not an issue. You explain the need but don't say who is making these pages, etc. IT can't do anything until you actually have something that is ready to be posted on the site. IT does not design websites. If something needs to be designed and built, you need to go through the WebDev team to do it. Since this site sounds dynamic, it will probably need a database, but that's not a problem.

Basically, it sounds like you just need to get some space set up in Subversion for the work to be done on the site. Once the site is in Subversion and has been reviewed by the WebDev team, then IT can set up operationfirefox.com with the pages in Subversion and set up the needed database for it.
Assignee: nobody → server-ops
Status: UNCONFIRMED → NEW
Component: www.mozilla.com → Server Operations
Ever confirmed: true
Product: Websites → mozilla.org
QA Contact: www-mozilla-com → justin
Version: unspecified → other
Andrew, thanks for filing a tracker bug.  Could you add some details about what technologies will be used, or is that something we can help with?  Is there a project wiki page somewhere that I can look at?

Comment 3

10 years ago
Has anyone assessed the need for QA testing?  If not, Please see Stephen Donner.  Normal process is to have QA test any new customer facing pages. I am marking this with whiteboard comment qa-p3 until we know more.
Whiteboard: [qa-p3]
(Reporter)

Comment 4

10 years ago
Morgamic: We will add you to the basecamp on mozilla.grouphub.com so that you can see the larger progress of this project.  

Unfortunately, I am not certain of the technologies being used on the page, but I think that it is mainly php and html.  There is also one page that is a form, so a database will have to exist behind that.  The form will consist of contact information and then one text-based question.

Also, I emailed the qa-execution alias over the weekend with this project to alert them of it.

Comment 5

10 years ago
About the QA stuff:
As noted above, Andrew emailed the qa-execution alias with the heads-up. I was planning on filing an official "please QA this site" bug once the site has actually been built.
(Assignee)

Comment 6

10 years ago
Moving out of Server Ops until there's something for them to do. Will be filing other relevant bugs shortly.
Assignee: server-ops → nobody
Component: Server Operations → Other
Product: mozilla.org → Websites
QA Contact: justin → other
Version: other → unspecified
(Assignee)

Comment 7

10 years ago
Stephen, the site is ready to be QA'd at the URL above. Expected launch is a week from today.

The only known issues I am aware of are that the rules page is missing content and there are some minor display quirks in IE. JavaScript is only used to pre-load images.

If you'd like me to file another bug for QA, just let me know.
Assignee: nobody → fligtar
(Assignee)

Comment 8

10 years ago
morgamic, would you mind reviewing the submission form when you get a chance?

http://svn.mozilla.org/projects/operationfirefox.com/trunk/submit.php

It can be tested on staging.
Status: NEW → ASSIGNED
As long as I don't post screenshots, can I host my test plan at http://wiki.mozilla.org, or should I do it on http://intranet.mozilla.org (this bug doesn't have its confidential flags set, and the page is behind LDAP auth, so...)?
(Assignee)

Comment 10

10 years ago
Either is fine - the LDAP auth is accessible by anyone with a CVS account, not MoCo only.
(In reply to comment #7)

<snip>

> The only known issues I am aware of are that the rules page is missing content
> and there are some minor display quirks in IE. JavaScript is only used to
> pre-load images.

Opera 9.23 on Windows, and Safari 2.0.4 on Mac, as well, have issues with the submit.php page (the form textfields break on a couple lines).
http://img490.imageshack.us/my.php?image=picture1jj4.png

screenshot of Safari 2.0.4 on Mac OS X 10.4
Test Plan with first-round results: http://wiki.mozilla.org/Operation_firefox_test_plan
(Assignee)

Comment 14

10 years ago
Thanks Stephen.

The line break is actually an issue on every page, it's just been made to look nice enough in Firefox at the expense of the other browsers. I'm trying to figure out the best way to fix it -- the HTML that the design agency gave us for it isn't doing it.

As you may have heard, the launch was moved back a week (for issues not relating to the website), so we have more time to figure it out.
(Assignee)

Comment 15

10 years ago
A few bugfixes on staging:
- I temporarily "fixed" the form issue by moving one more field under the divider, so it should look fine in IE and Safari now, and only slightly weird in Firefox.
- Everything isn't centered in IE anymore
- Added favicon
- IE doesn't submit the value of image submit buttons, so the form was unsubmittable in IE
Alias: operationfx
I ran through my tests again on staging and the issues mentioned above are indeed fixed; we don't do much form validation...should we?  (Kind of late to be asking, I guess.)

For instance, I can submit empty-but not null--strings such as " " (space) into every field and it's accepted.  Not sure how crazy we want to get with the validation.  Really, it's just more work on the receiver to sort out bogus submissions, and I doubt that whomever does that will take the time to figure out bogus (spammy) entries, so probably not an issue.

Other than that, this looks good to go from my side, so I've updated http://wiki.mozilla.org/Operation_firefox_test_plan by removing the reference to the now-fixed form-textfield break issue.
(In reply to comment #16)

<snip>
 
> For instance, I can submit empty-but not null--strings such as " " (space) into

By this comment, you can tell I've never had a CS course; an empty string is "", not " ", of course.
Someone--Andrew?--mark this fixed, and I'll mark it verified, since it's live.
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Thanks Justin.  Verified FIXED, as it's on production.
Status: RESOLVED → VERIFIED

Comment 20

10 years ago
Under the FAQ, we currently have the following:

"Do the stickers ruin surfaces?

"No, the stickers utilize static electricity to cling to walls, so they can be easily removed without leaving any damage behind."

We need to change it to this:

"Do the stickers ruin surfaces?

"The stickers use a light adhesive similar to Post-it Note (R).  Each sticker comes with specific instruction on how to apply the sticker.  If followed, the stickers should not damage the surface."
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 21

10 years ago
FAQ updated and pushed.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Deployed to production with the changes in comment 20; verified.  My grammar hat is not on today, so I really don't know if "instruction" ought to be plural; most dictionaries say "usually: instructions", but that's a quibble.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.