Closed Bug 398094 Opened 13 years ago Closed 12 years ago

all graphics/icons render at too large a size

Categories

(Core Graveyard :: GFX: Gtk, defect, major)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 394103

People

(Reporter: wabidwoveren, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007092904 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007092904 Minefield/3.0a9pre

On a fresh install of linux, when i add gran paradiso, all images and toolbar icons are drawn at the wrong size

Reproducible: Always

Steps to Reproduce:
0.Use Ubuntu Gutsy Gibbon
1.Clear settings
2.Install Gran Paradiso
3.Open Gran Paradiso


Actual Results:  
Images are too big

Expected Results:  
Images are the right size

I was told it may be layout.css.dpi but it is set to -1 in both browsers.  changing it does nothing.

Screen resolution is 1920x1200
Screen DPI is 96
No idea what this means, but..

(gecko:8794): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.14.1/gobject/gsignal.c:2180: invalid unclassed object pointer for value type `GdkScreen'

(gecko:8794): Gdk-CRITICAL **: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed

(gecko:8794): GLib-GObject-CRITICAL **: g_object_get_data: assertion `G_IS_OBJECT (object)' failed

(gecko:8794): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.14.1/gobject/gsignal.c:2180: invalid unclassed object pointer for value type `GdkScreen'
Try right click on Toolbar -> Customize -> check 'use small icons'

alternate way: View -> Toolbars -> Customize -> check 'use small icons'
look at the picture, not only are toolbars large.  the image from google.com is also enlarged
look at the picture, not only are toolbars large.  the image from google.com is also enlarged
ok it looked like you zoomed in on the page. But the use small icons should fix the toolbars.
if i change small icons its the same problem, just slightly smaller.  I dont have the page zoomed.  It is also a problem in gnome, xfce and kde.  It is still a problem with compiz enabled and disabled.

If you want i can take a screenshot with large and small toolbars.  Don't you find it odd that the icons and images are both scaled by the same size.
Also shouldn't zoom change the text size.
And even the throbber is the wrong size.
i installed http://ted.mielczarek.org/code/mozilla/fullpagezoom.xpi

if i click zoom out once, and increase the text size, everything on the page is fixed.  The rest of the browser is still too big
Flags: blocking-firefox3?
We don't block on unconfirmed bugs - please get some STR or a confirmation before renominating.
Flags: blocking-firefox3?
Rob, do you still see this using the latest trunk nightly?
I'm seeing this same issue on Fedora Core 8, with a 3840x1200 dual monitor setup.

My X server is set at 98 DPI.
Confirming based on original poster and comment 14.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Flags: blocking-firefox3?
moving to core, moving flag over, but looks like it should block...
Component: General → GFX: Gtk
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → gtk
Moving flag over for real...
Flags: blocking1.9?
Is this a dupe of bug 394103 (or visa-versa)?
This is a dupe of 394103.

Also, setting my layout.css.dpi to 96 also fixed the problem for me.

Thanks!
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: blocking1.9?
Resolution: --- → DUPLICATE
Duplicate of bug: 394103
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.