File selection dialog for upload always starts in SM 2.0a1's program directory

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

In SM 2.0a1, when you attempt to upload a file, such as uploading an 
attachment to a bugzilla bug, and you click the Browse button, the 
File Upload dialog appears, and it initially is positioned in the
directory where SM's executable program is located, the current working
directory where the program started.  ALWAYS.  If you have previously
done another upload in the same process lifetime, and repositioned the
File Upload dialog to a different directory, that other directory is not 
remembered, not even for the process lifetime.

In SM before version 2.0a1, when you attempt to upload a file, and you 
click the Browse button, the File Upload dialog appears, and it initially 
is positioned in the same directory as the directory for file downloads.  

I believe that in SM before 2.0a1, file uploads and file downloads shared 
the same configuration.  If you have file downloads configured to always 
use a certain directory, then file uploads start in that directory.  
If you have file downloads configured to remember the last directory and
start there, then the file upload dialog starts in that remembered last
download directory, and whatever directory you switch to (in the file 
upload dialog) would also be the starting directory for the next file 
download dialog.  

Now, in 2.0a.1, it appears that the directories for uploads and downloads 
are completely decoupled, and upload directories are not configurable in
any way, and are not remembered from one upload to the next.

The present behavior is really a pain when you have a large number of files
to upload.  Having to reposition the File Upload dialog again and again for
every file is really tedious.
Does SeaMonkey 2.0a1 have the patch for bug 240644, that was since backed out? That might explain what you're seeing.

Comment 2

9 years ago
I don't see this, does this still happen in current versions?
Status: NEW → UNCONFIRMED
I used to see this a LOT, but haven't seen it for a long time now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.