zero size window on edit calendar

RESOLVED INCOMPLETE

Status

Calendar
Calendar Views
--
major
RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: Alien Life Form, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Sunbird 0.5, Lightning 0.5

After a while calendars are displayed as "<Unknown 1>..." Editing a calendar (I use only remote webdav, caldav and google) becomes impossible as the edit window is zero-sized (titlebar only). Error console complains of a general failure in calCalendarManager.js line 548 in storageProviderStep (i'll add the precise error next time I hit it). Editing/adding en event is equally impossible as the calendar dropdown is empty and inoperable. Sometimes a restart fixes the problem, sometimes a reinstall is needed. In spite of this, events are displayed for all calendars.

Everything is as if calendar proeprty info is read incorrectly or not at all. Reloading remote has no effect.


Sometimes restarting fixes it, sometimes a reinstall is called or. M


Reproducible: Sometimes

Steps to Reproduce:
1. Happens often, more consistently in Sunbird than in Lightning. My setup has 5 webdav calendar, 1 Google calendar and no local calendars. Unfortunately, I have not found a way to riproduce it.
2.
3.



Platform is XP home.

May be unrelated, but the error console also shows errors about being unable to load todo.xml (though the To Do list gets displayed albeit uncorrectly).
(Reporter)

Comment 1

11 years ago
The error as shown in the console is:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatementWrapper.step]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Programmi/Mozilla%20Sunbird/js/calCalendarManager.js :: anonymous :: line 548"  data: no]
Source File: file:///C:/Programmi/Mozilla%20Sunbird/js/calCalendarManager.js
Line: 548

In Sunbird, I can still see the cal. names (as opposed to the unknown... in lightning)

Comment 2

11 years ago
Have you tried to reproduce the problem with lightning&Sunbird 0.7 RC1 (with new profile)?
(Reporter)

Comment 3

11 years ago
I tried 0.7 RC1 moments ago and the problem did not show, but I do not think the test is very significant because:
1) It did disable the Google cal provider (and so I am testing under different conditions);
2) (Because of (1)) I did not take much time to work with it, and, as stated, the problem shows up "after a while" (for lack of a better definition)

Because of (1) I will be unable to test Lightning until the Google provider extension come out, as I need a functioning calendar for my work.
Regarding the gdata provider, a new version will be released as soon as 0.7 is not an rc anymore. For now you can edit the maxVersion in the install.rdf, that should work fine.
Bug 359564 (and it's duplicates), Bug 367620 or Bug 364957 report a similar error message if the sqlite database file (storage.sdb) is corrupted or not readable/writable e.g. because there is no disk space left or the file is read only. Could you check if you are experiencing a similar situation?
Reporter, any news regarding the information requested in Comment #2 and Comment #5?
Reporter, please retest and update your bug report as requested in Comment #6.
No response from reporter. Feel free to reopen the bug report if you can still
reproduce. -> Resolving as INCOMPLETE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.