a window to add a new bookmark has no title bar and non-center position

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: j, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007100104 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007100104 Minefield/3.0a9pre

a window to add a new bookmark has no title bar and non-center position when trying to add a bookmark. Bookmark is added automatically, even when escaping from the window.

Reproducible: Always

Steps to Reproduce:
1. open any web page
2. add to bookmarks (either through menu or ctrl+d)
3. window to add a new bokmark appears
Actual Results:  
The window has no title bar or a window border. The position of the window seems to be at the end of the address bar, not in the center of the screen or the main firefox window. If I don't interact with the 'add-new-bookmark' window, either by pressing escape or by clicking in the main window, the bookmark window disappears but the bookmark gets added anyway. In fact, it seems to be added at the time I press ctrl+D, not when I click Done. Also, the button 'Delete' doesn't make sense, because I haven't added the bookmark yet, I am just contemplating adding.

Expected Results:  
Version 3a7 worked fine and as expected. Unless I click OK on that window, I don't expect to see the bookmark in the bookmarks.

Comment 1

11 years ago
It's going to take some time for users to become familiar with and understand the new bookmarking behavior. Everything you described is intended.  We want bookmarking to be a "as few clicks as possible" function.  Now when you click the "Bookmark this Page"  that's exactly what it does.  The "window" as you describe is aligned with the "Star," which indicates and acts as access point to that page's bookmark status. If you want to remove the bookmark you just added (star yellow), click "delete". Any page that you visit which you have bookmarked will have a yellow star.  This is really a step up in how bookmarking works. Just takes a little getting used to. :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.