Printing one or more web pages causes the page headers to print alone on separate pages.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Martin Brule Jr., Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30], URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

If I print one or more web pages from Firefox, like www.cnn.com for example, the page header info prints as a single line on a separate piece of paper.  Firefox is the only program that prints this way.  IE works fine for printing.  I also test printed some text from NotePad and it printed multiple pages ok without printing extra useless pages.

To further explain, printing 3 pages actually causes 6 to print, 3 docs to print plus a header page for each printed page.

Reproducible: Always

Steps to Reproduce:
1.open Firefox and browse to www.cnn.com or any website
2.print 1 page
3.print 2 or more pages
Actual Results:  
Printing one page caused two to print - the header page and the actual info page.
Printing more than one page caused this same single-line header page to print along with each page of the actual print job.

Expected Results:  
One page should have printed when I selected ok to print one page.  One header page for each printer page prints out.  

Basically, anything printed from Firefox will use double the amount of paper because of the webpage header being printed alone onto a separate page.

I called Lexmark to get help.  They helped me determine that the printer isn't the problem.  It seems to be coming from Firefox since nothing else on my laptop exhibits this behavior.         

My computer runs XPpro SP2.

Comment 1

9 years ago
Created attachment 391147 [details]
Thunderbird version 2.0.0.22 (20090605) print preview bug

I am also having printing problems in Thunderbird version 2.0.0.21 and/or
2.0.0.22 (Mac OSX 10.5.7). When printing, not all of the content on page is
printed, it cuts off part of the message body from bottom of page two.  Huge
white space with email header info (TO, From, Subj, etc., then the remaining of
page is blank on page one.  page 2 displays the message body (validated HTML
email)<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
        "http://www.w3.org/TR/html4/loose.dtd"> but again cut off the content
not able to be display on a single printed page. Page three prints the footer
of the html page. I upgraded to (latest)Thunderbird V 2.0.0.22 with no better
results.
The email was sent from another source to two addresses, One I check with
Thunderbird - resulting in missing data (only when printing), and another
opening in Apple Mail, prints 100% correctly. Something definitely wrong w
Thunderbird.  I am able to reproduce this on multiple Macs w/ Thunderbird.
humm...  I'd hate to switch to Apple Mail.  Anything.... anybody....help!
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch

Comment 3

8 years ago
Works for me - Mozilla/5.0 (X11; Linux x86_64; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre

CNN may have redesigned their page since this bug was filed. Comment 1 is unrelated to this bug. It shows a different bug in which content does not get printed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Attachment #391147 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.