[FIX]"ASSERTION: Should be in an update while creating frames" with xul listbox

RESOLVED FIXED in mozilla1.9beta1

Status

()

P1
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: jruderman, Assigned: bzbarsky)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
mozilla1.9beta1
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 ?
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Created attachment 283247 [details]
testcase

Loading the testcase (in Mac trunk debug) triggers:

###!!! ASSERTION: Should be in an update while creating frames: 'mUpdateCount != 0', file /Users/jruderman/trunk/mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6682

This assertion was added in bug 398108.
Flags: blocking1.9?
See, that's the think.  I tried testing listboxes before landing bug 398108 because I expected them to assert...  but they didn't.  Neither does that testcase, in my build.

What's the stack you see to the assert?
(Reporter)

Comment 2

11 years ago
Created attachment 283270 [details]
stack trace for the assertion

Stack trace for the first instance of the assertion.
Created attachment 283293 [details] [diff] [review]
Fix

I still don't know why I couldn't reproduce....
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #283293 - Flags: superreview?(dbaron)
Attachment #283293 - Flags: review?(dbaron)
Priority: -- → P1
Summary: "ASSERTION: Should be in an update while creating frames" with xul listbox → [FIX]"ASSERTION: Should be in an update while creating frames" with xul listbox
Target Milestone: --- → mozilla1.9 M9
Comment on attachment 283293 [details] [diff] [review]
Fix

r+sr=dbaron, although we should probably invest in guard objects for this at some point...
Attachment #283293 - Flags: superreview?(dbaron)
Attachment #283293 - Flags: superreview+
Attachment #283293 - Flags: review?(dbaron)
Attachment #283293 - Flags: review+
Comment on attachment 283293 [details] [diff] [review]
Fix

a1.9=dbaron
Attachment #283293 - Flags: approval1.9? → approval1.9+
Checked in.  Could use a test in layout/crashtests or whatever bug 397725 decides on.
Flags: in-testsuite?
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

11 years ago
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.