Closed Bug 398334 Opened 13 years ago Closed 13 years ago

"ASSERTION: previous transaction is not finished!"

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
All
defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla1.9beta5

People

(Reporter: jruderman, Assigned: mats)

References

()

Details

(Keywords: assertion)

Attachments

(2 files)

Attached file stack trace
I hit this assertion a few times today:

###!!! ASSERTION: previous transaction is not finished!: '!sTargetFrame', file /Users/jruderman/trunk/mozilla/content/events/src/nsEventStateManager.cpp, line 299

I think I hit it by clicking a link from one bug report to another and two-finger scrolling before the second page started to load.  I can't reproduce it reliably.
Also occurs on Linux (100% reproducible):
1. load a Bugzilla bug page (logged in)
2. hover the "Product" combobox
3. mouse-wheel scroll down
Severity: normal → minor
OS: Mac OS X → All
Attached patch Patch rev. 1Splinter Review
If we started a transaction for the combobox (because it returned true from
CanScroll()) we need to end it before continuing the loop.

Not really important to fix for 1.9 but it seems low risk if we want it.
Assignee: nobody → mats.palmgren
Status: NEW → ASSIGNED
Attachment #307696 - Flags: review?(masayuki)
Attachment #307696 - Flags: superreview?(roc)
Attachment #307696 - Flags: superreview?(roc) → superreview-
Comment on attachment 307696 [details] [diff] [review]
Patch rev. 1

oops
Attachment #307696 - Flags: superreview- → superreview+
Attachment #307696 - Flags: approval1.9?
Comment on attachment 307696 [details] [diff] [review]
Patch rev. 1

a1.9=beltzner
Attachment #307696 - Flags: approval1.9? → approval1.9+
mozilla/content/events/src/nsEventStateManager.cpp 	1.734 

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta5
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.