Style access using DOM should take default units (px?)

VERIFIED INVALID

Status

()

Core
DOM: CSS Object Model
P3
enhancement
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Taras Tielkes, Assigned: jst)

Tracking

({compat, dom2})

Trunk
Future
compat, dom2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX ? -- non standards compliant)

(Reporter)

Description

18 years ago
This doesn't work:
-----------------------------------
oTable.style.borderWidth = "14";
-----------------------------------

While this does:
-----------------------------------
oTable.style.borderWidth = "14px";
-----------------------------------

Comment 1

18 years ago
setting status to new
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

18 years ago
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
I think there's another, better analyzed bug on this.  Lengths without units are
technically invalid CSS.  I think the "bug" here is that we're not passing the
quirks mode to the CSS parser created to evaluate the CSS given in the DOM
changes.  One could argue that perhaps we don't need to, though, since existing
pages don't depend on this quirk.
Keywords: dom2
Component: DOM Level 2 → DOM Style
Taking QA Contact on all open or unverified DOM Style bugs...
QA Contact: vidur → ian
Marking INVALID as per David's comments. We have enough other DOM CSS bugs 
without having to fix this one.
Severity: normal → enhancement
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: compat
Resolution: --- → INVALID
Whiteboard: WONTFIX ? -- non standards compliant

Comment 6

17 years ago
and VERIFIED invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.