Can't set table border using DOM

VERIFIED WORKSFORME

Status

()

Core
DOM: CSS Object Model
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Taras Tielkes, Assigned: jst)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
All these three methods of setting the table border width work with PR1, but 
fail with yesterday's (18may) nightly build.

oTable.style.borderWidth = "14px";
oTable.border = "5px";
oTable.setAttribute("border","14px");
Do you have a testcase?  (I would think you wouldn't want the "px" on the latter
two methods because they deal with the HTML attribute, not the CSS property (as
the first does).)
(Assignee)

Comment 2

18 years ago
This bug has been marked "future" because the original netscape engineer

workingon this is over-burdened. If you feel this is an error, that you or

another known resource will be working on this bug,or if it blocks your work in

some way -- please attach your concern to the bug for reconsideration.

Target Milestone: --- → Future

Comment 3

18 years ago
setting to New because it has a milestone assigned
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 4

18 years ago
Created attachment 12428 [details]
Test case

Comment 5

18 years ago
Created attachment 12429 [details]
Screen shot shows it works fine (2000072920/MacOS9)

Comment 6

18 years ago
Works for me under 2000072920/MacOS9; see attachments.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Component: DOM Level 2 → DOM Style
Taking QA Contact on all open or unverified DOM Style bugs...
QA Contact: vidur → ian
QA Contact: ian → amar
(Reporter)

Comment 8

17 years ago
Verifying.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.