Thunderbird options / preferences reversed between Sameplace and Lightning

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: grillo_n, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; pt-BR; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 2.0.0.6 (20070728)

I have Sameplace 0.7.1.2007091016 and Lightning 0.7 2007100203 extensions installed and, when I open TB options window, the Lightning options are shown under Jabber tab and vice-versa. It gets corrected after opening options window once or twice after Lightning installation or update.

Reproducible: Always

Steps to Reproduce:
1.Install Sameplace extension
2.Install Lightning extension
3.Open Preferences window in Thunderbird
Actual Results:  
Jabber tab shows Lightning options and Lightning tab show Jabber options

Expected Results:  
Each extension options set should appear under its own tab
(Reporter)

Comment 1

11 years ago
Created attachment 283343 [details]
Jabber settings shown under Lightning tab
(Reporter)

Comment 2

11 years ago
Created attachment 283344 [details]
Lightning settings shown under Jabber tab
Not a thunderbird bug. Don't know if it's a lighting either... anyway. Moving.
Component: Preferences → Lightning Only
Product: Thunderbird → Calendar
QA Contact: preferences → lightning

Comment 4

11 years ago
Well if you want to use Sameplace you have to install xmpp4moz extension first. And the problem you reported appears after install of xmpp4moz
(Reporter)

Comment 5

11 years ago
Magnus, I have no idea of which component causes the bug, since it only happens together. Both add tabs to the Preferences window.
Which component handle the tabs? Can extensions get control of it to include their own tabs? If yes, one of the extensions is doing the job incorrectly. If not, probably Thunderbird is failing to correctly organize the tabs.
Omar, I also have xmpp4moz, just omitted it because it's a dependency. In fact, the problem occurs after all 3 extensions (xmpp4moz, SamePlace and Lightning) are installed.

Is there something I can do to isolate the buggy component?
Thanks.
I can confirm the issue by installing

  - Lightning 0.7 (2007100704)
  - xmpp4moz 0.5.1.2007090906

in a new profile using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.8pre) Gecko/2007100603 Thunderbird/2.0.0.7pre.
But it works if I install
  - Lightning 0.6a1 (2007100706)
  - xmpp4moz 0.5.1.2007090906 (after install.rdf adjustment)
in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007100503 Thunderbird/3.0a1pre.

So maybe this is a known issue that is already fixed on Trunk?
(Reporter)

Comment 8

11 years ago
If it's fixed on Trunk (how can we tell?), does it mean it will only work correctly on TB3?
BTW, I'm not sure if I identified the correct product in the bug description. From the talks above, it seems related to Thunderbird itself.
Thanks,
Emerson
Still happening with 0.9pre? Setting qawanted in hopes of finding out why this is happening (please check dom inspector if ids are messed up, or possibly xmpp4moz code to see how they are overlaying), and in hopes of finding a workaround.
Keywords: qawanted
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 10

11 years ago
Hi.
It doesn't happen anymore because SamePlace preferences were moved from the Thunderbird preferences window to a SamePlace separated window.
Best regards
Thanks for the note!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.