Status

()

--
enhancement
RESOLVED DUPLICATE of bug 280383
11 years ago
11 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Occasionally I'm doing some research in Firefox, and I want to save the results of my research on disk for future reference.  If these pages are opened in multiple tabs, currently the only way to achieve my goal is by switching to each tab and saving the page manually.  This doesn't work well for cases where there are a lot of tabs to save.

The nearest available feature is "Bookmark All Tabs" from the Bookmarks menu, which doesn't give me what I want, but at least allows me to save all of the links to the pages open in each tab quickly.

I think a new "Save All Tabs" in the file menu is worth adding, which would prompt the user for a location to save the pages to, and would handle things like duplicate file names and saving both pages and other documents (such as images) in the saving process well.
I think the extension ScrapBook is what you want: https://addons.mozilla.org/en-US/firefox/addon/427
It has the options you mentioned in a separate menu in the menu bar.
Component: File Handling → General
QA Contact: file.handling → general

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 280383
You need to log in before you can comment on or make changes to this bug.