user preference for the position of the comment box

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Creating/Changing Bugs
P2
enhancement
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Albert Ting, Assigned: Matt McHenry)

Tracking

(Blocks: 1 bug)

3.1.2
Bugzilla 4.0
Bug Flags:
approval +

Details

(Whiteboard: [wanted-bmo])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 

bugzilla.mozilla.org has a "Position of the comment box" user preference.  I couldn't find this feature in the latest 3.1.2 branch, nor could I find a BZ ticket.  

In any case, can this be part of the default package?

Thanks,
Albert

Reproducible: Always

Comment 1

10 years ago
Yeah, this would be a useful and valid preference, because the number of people who want it in different places seems to be pretty evenly split.
Blocks: 345674
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Version: unspecified → 3.1.2
Whiteboard: [wanted-bmo]
(Assignee)

Comment 2

9 years ago
This feature on b.m.o was bug 367003; unfortunately there's no patch on that bug.  In bzr (http://dm-bugstage01.mozilla.org/bmo/3.2+), it's mostly all jumbled up in the huge revision 6118, "Bring the Mozilla 3.0 customizations forward into the current Bugzilla 3.2 branch code", with some changes to edit.html.tmpl in rev 6120.  (And maybe others that I haven't discovered yet.)
(Assignee)

Comment 3

8 years ago
Created attachment 360091 [details] [diff] [review]
patch against 3.2

Ported from the bzr revisions mentioned in the previous comment.  In Install.pm, I wasn't sure whether to leave the existing attribution or replace it with mine, so guidance on that is appreciated.
Attachment #360091 - Flags: review?(mkanat)

Comment 4

8 years ago
I suspect that once bug 462488 is complete, we won't need this anymore.
(Assignee)

Comment 5

8 years ago
Created attachment 360507 [details] [diff] [review]
patch against 3.2.2

Okay, I'll hold off on requesting review or trying to port this to trunk, then.  3.2.2 had a minor conflict, so here's an updated patch in case it's useful to anyone before that other bug is fixed.
Attachment #360091 - Attachment is obsolete: true
Attachment #360091 - Flags: review?(mkanat)

Comment 6

8 years ago
I would accept a patch to move the comment bits into a BLOCK, though, which would make this customization much easier to maintain.
(Assignee)

Comment 7

7 years ago
Created attachment 448073 [details] [diff] [review]
patch against 3.6

Something else in 3.6 moved the comment bits into a BLOCK, and that makes this much simpler.
Attachment #360507 - Attachment is obsolete: true
Attachment #448073 - Flags: review?(mkanat)

Updated

7 years ago
Target Milestone: --- → Bugzilla 3.8

Comment 8

7 years ago
Comment on attachment 448073 [details] [diff] [review]
patch against 3.6

>Index: Bugzilla/Install.pm
>+    # 2009-02-01 mozilla@matt.mchenryfamily.org -- Bug 398473
>+    comment_box_position => { options => ['before_comments', 'after_comments'],
>+                              default => 'after_comments' },

  The default should be what it is now, which is before_comments.

>Index: template/en/default/global/setting-descs.none.tmpl
>+   "comment_box_position"             => "Position of the additional comments box",

  I'd capitalize Additional Comments.
Attachment #448073 - Flags: review?(mkanat) → review-

Updated

7 years ago
Assignee: create-and-change → mozilla
(Assignee)

Comment 9

7 years ago
Created attachment 448083 [details] [diff] [review]
patch against 3.6, v2
Attachment #448083 - Flags: review?(mkanat)
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Attachment #448073 - Attachment is obsolete: true

Comment 10

7 years ago
  Thanks! Will test the patch some time soon and get back to you on it.

Comment 11

7 years ago
Comment on attachment 448083 [details] [diff] [review]
patch against 3.6, v2

This looks and works great!

There's only one thing that I want: when the comment box is at the bottom of the page, I want an "Add Comment" link that will take me to the comment box with the Save Changes button visible.
Attachment #448083 - Flags: review?(mkanat) → review+

Updated

7 years ago
Flags: approval+
(Assignee)

Comment 12

7 years ago
Since you approved the patch, does that mean I should enter a separate bug for the "Add Comment" link?  When the comment box is at the top, do you want a similar link after the last comment at the bottom?

Comment 13

7 years ago
(In reply to comment #12)
> Since you approved the patch, does that mean I should enter a separate bug for
> the "Add Comment" link? 

  Yeah, sure.

> When the comment box is at the top, do you want a
> similar link after the last comment at the bottom?

  Oh, yeah, why not.

Comment 14

7 years ago
Thanks for your work on this patch, Matt! :-)

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Install.pm
modified template/en/default/bug/edit.html.tmpl
modified template/en/default/global/setting-descs.none.tmpl
Committed revision 7222.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: relnote
Resolution: --- → FIXED
(Assignee)

Comment 15

7 years ago
Sure!  :)  The new bug for the "Add Comment" link is bug 574338.

Comment 16

7 years ago
Added to the release notes in bug 604256.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.