Menu bar (chrome) not exposed properly

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: steve, Assigned: aaronlev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091005 Minefield/3.0a8pre
Build Identifier: Trunc Minefield

A number of problems with how menus are exposed in at-spi.

The menu children of the menu bar are not state_focusable when they should be.
They have a click action but it does nothing. They are state 'showing' and 'visible' though they are not visible. I think the structure is wrong (compare with a combo in the document) and should be: for each menu there should be a menu item, focusable, visible, showing etc with an 'open' action. The open action should show the pulldown child menu which then has state showing etc.

Reproducible: Always

Steps to Reproduce:
1.look at menu bar in accerciser
2.
3.
Can't reproduce on trunk any more. Worksforme. Steve, can you verify please?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

10 years ago
right now I'm only seeing a single redundant object below the top level frame 
That's with latest nightly and I upgraded accerciser too.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081105 Minefield/3.1b2pre
(Reporter)

Comment 3

10 years ago
Confirmed WFM.
I'm happy with the action name 'Click' on the menus
Thanks
You need to log in before you can comment on or make changes to this bug.