Last Comment Bug 398505 - nsMathMLmactionFrame::Init munges style context
: nsMathMLmactionFrame::Init munges style context
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: mozilla9
Assigned To: Frédéric Wang (:fredw)
:
Mentors:
Depends on:
Blocks: maction
  Show dependency treegraph
 
Reported: 2007-10-03 19:56 PDT by Boris Zbarsky [:bz] (Out June 25-July 6)
Modified: 2011-09-14 07:24 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove nonstandard actiontype "restyle" of maction. r=karlt (bug 398505) (3.69 KB, patch)
2011-08-23 06:10 PDT, Frédéric Wang (:fredw)
karlt: review+
emorley: checkin+
Details | Diff | Review
remove nonstandard actiontype "restyle" of maction on MathML demo pages. (6.48 KB, patch)
2011-08-23 06:10 PDT, Frédéric Wang (:fredw)
karlt: review+
karlt: checkin+
Details | Diff | Review

Description Boris Zbarsky [:bz] (Out June 25-July 6) 2007-10-03 19:56:01 PDT
nsMathMLmactionFrame::Init reresolves its style context after munging an attribute... it's possible to craft style rules so that it'll actually end up with "display: none" after that, but still have a frame.  That's bad.
Comment 1 Frédéric Wang (:fredw) 2011-04-22 03:50:33 PDT
I suggest to remove the actiontype="restyle". See bug 544036 comment 1
Comment 2 Karl Tomlinson (ni?:karlt) 2011-04-24 21:49:45 PDT
Agreed.
Comment 3 Frédéric Wang (:fredw) 2011-08-23 06:10:06 PDT
Created attachment 555084 [details] [diff] [review]
remove nonstandard actiontype "restyle" of maction. r=karlt (bug 398505)
Comment 4 Frédéric Wang (:fredw) 2011-08-23 06:10:53 PDT
Created attachment 555085 [details] [diff] [review]
remove nonstandard actiontype "restyle" of maction on MathML demo pages.
Comment 5 Karl Tomlinson (ni?:karlt) 2011-09-04 23:50:12 PDT
Comment on attachment 555085 [details] [diff] [review]
remove nonstandard actiontype "restyle" of maction on MathML demo pages.

>-לחץ עם העכבר בכל מקום באיזור הצהוב כדי להגדיל/להקטין בעזרת RESTYLE:
>+לחץ עם העכבר בכל מקום באיזור הצהוב כדי להגדיל/להקטין:

>-คลิกตรงไหนก็ได้ในพื้นที่สีเหลือง เพื่อ ย่อ/ขยาย โดยใช้ RESTYLE:
>+คลิกตรงไหนก็ได้ในพื้นที่สีเหลือง เพื่อ ย่อ/ขยาย :

Did you check that it is appropriate to remove these words in these languages?
Comment 6 Frédéric Wang (:fredw) 2011-09-05 10:13:17 PDT
(In reply to Karl Tomlinson (:karlt) from comment #5)
> Comment on attachment 555085 [details] [diff] [review]
> remove nonstandard actiontype "restyle" of maction on MathML demo pages.
> 
> >-לחץ עם העכבר בכל מקום באיזור הצהוב כדי להגדיל/להקטין בעזרת RESTYLE:
> >+לחץ עם העכבר בכל מקום באיזור הצהוב כדי להגדיל/להקטין:
> 
> >-คลิกตรงไหนก็ได้ในพื้นที่สีเหลือง เพื่อ ย่อ/ขยาย โดยใช้ RESTYLE:
> >+คลิกตรงไหนก็ได้ในพื้นที่สีเหลือง เพื่อ ย่อ/ขยาย :
> 
> Did you check that it is appropriate to remove these words in these
> languages?

I tried to translate into English with Google translate and that seems to be correct.
Comment 7 Bill Gianopoulos [:WG9s] 2011-09-05 11:18:40 PDT
(In reply to Karl Tomlinson (:karlt) from comment #5)
> Comment on attachment 555085 [details] [diff] [review]
> remove nonstandard actiontype "restyle" of maction on MathML demo pages.
> 
> >-לחץ עם העכבר בכל מקום באיזור הצהוב כדי להגדיל/להקטין בעזרת RESTYLE:
> >+לחץ עם העכבר בכל מקום באיזור הצהוב כדי להגדיל/להקטין:
> 
> >-คลิกตรงไหนก็ได้ในพื้นที่สีเหลือง เพื่อ ย่อ/ขยาย โดยใช้ RESTYLE:
> >+คลิกตรงไหนก็ได้ในพื้นที่สีเหลือง เพื่อ ย่อ/ขยาย :
> 
> Did you check that it is appropriate to remove these words in these
> languages?

Exactly what fonts am I supposed to have installed so that this comment makes any sense whatsoever?
Comment 8 Karl Tomlinson (ni?:karlt) 2011-09-05 21:46:23 PDT
(In reply to Frédéric Wang (:fred) from comment #6)
> I tried to translate into English with Google translate and that seems to be
> correct.

OK.  Sounds fine, thanks.

(In reply to Bill Gianopoulos from comment #7)
> Exactly what fonts am I supposed to have installed so that this comment
> makes any sense whatsoever?

I don't think any fonts will.  There seems to be an encoding (or similar) problem with Bugzilla's "Edit Attachment As Comment".
Comment 9 Ed Morley [:emorley] 2011-09-13 17:20:07 PDT
Where is the 2nd patch supposed to be landing, seeing as the files for it don't exist in m-c?

In instances where non-standard landing of patches is required, please can you add suitable instructions to the whiteboard, to make it easier not only for the person doing the checkin-neededs, but also people doing the subsequent inbound -> m-c merge. Thanks :-)
Comment 10 Ed Morley [:emorley] 2011-09-13 17:38:07 PDT
Try run for the first patch:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=5a17479d7da9
Comment 11 Bill Gianopoulos [:WG9s] 2011-09-13 17:43:26 PDT
(In reply to Ed Morley [:edmorley] from comment #9)
> Where is the 2nd patch supposed to be landing, seeing as the files for it
> don't exist in m-c?
> 
> In instances where non-standard landing of patches is required, please can
> you add suitable instructions to the whiteboard, to make it easier not only
> for the person doing the checkin-neededs, but also people doing the
> subsequent inbound -> m-c merge. Thanks :-)

I believe the second patch is for the www.mozilla.org webserver.
to be landed relative to:

http://www.mozilla.org/projects/mathml/

I suspect the checkin-needed was probably intended to refer to the first patch only.
Comment 12 Karl Tomlinson (ni?:karlt) 2011-09-13 17:48:08 PDT
Comment on attachment 555085 [details] [diff] [review]
remove nonstandard actiontype "restyle" of maction on MathML demo pages.

http://viewvc.svn.mozilla.org/vc?view=revision&revision=95002
Comment 13 Ed Morley [:emorley] 2011-09-14 01:18:13 PDT
Comment on attachment 555084 [details] [diff] [review]
remove nonstandard actiontype "restyle" of maction. r=karlt (bug 398505)

https://hg.mozilla.org/integration/mozilla-inbound/rev/c576f8acafd6
Comment 14 Matt Brubeck (:mbrubeck) 2011-09-14 06:50:06 PDT
https://hg.mozilla.org/mozilla-central/rev/c576f8acafd6

Note You need to log in before you can comment on or make changes to this bug.