PRBool abuse in nsDocShell.cpp

RESOLVED DUPLICATE of bug 671417

Status

()

RESOLVED DUPLICATE of bug 671417
11 years ago
7 years ago

People

(Reporter: taras.mozilla, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
This needs to be rewritten.

--- docshell/base/nsDocShell.cpp
+++ docshell/base/nsDocShell.cpp
@@ -214,1 +214,1 @@
-static PRBool gValidateOrigin = (PRBool)0xffffffff;
+static PRBool gValidateOrigin = (PRBool)(0 != 0xffffffff);
@@ -3462,1 +3462,1 @@
-    if (gValidateOrigin == (PRBool)0xffffffff) {
+    if (gValidateOrigin == (PRBool)(0 != 0xffffffff)) {

Comment 1

7 years ago
Fixed by a part of bug 671417.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671417
You need to log in before you can comment on or make changes to this bug.