Closed Bug 398648 Opened 13 years ago Closed 13 years ago

file:// URL sometimes gives "File not found" after reload

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 322686

People

(Reporter: benoit.hudson+bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Sometimes (see 'steps to reproduce'), when developing HTML files on local disk and loading them via file:/// URLs, reload gives me a spurious 'file not found.'  When this happens, selecting the location bar and hitting enter always works.

Reproducible: Sometimes

Steps to Reproduce:
1. open file:///long/path/to/file.html
2. modify the file (don't delete it -- just modify it)
3. reload using Apple-R.  Sometimes: get "File not found"
4. if so, reload by clicking the "Try again button."
5. reload by clicking the location bar and hitting enter
Actual Results:  
Step 1 always works: if the file is there, firefox finds it.

On step 3, sometimes I get a File not found dialog.  I can't reproduce it every time yet, but it seems like it never happens when the file shrinks or is unmodified, and sometimes happens when it grows.  It happens often, but not repeatedly (undoing the modification and redoing it does not necessarily trigger the bug).

If step 3 triggered the bug, step 4 never works.  It's not clear to me that clicking the button has any effect.

Step 5 always works: it reloads the file, including any changes.  Thus, there's an easy workaround, which is to hit Apple-L <ret> instead of Apple-R when reloading to develop web pages in file:// URLs.

Expected Results:  
The file exists, so I should never get 'file not found.'
Dup of bug 322686?
Indeed.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322686
You need to log in before you can comment on or make changes to this bug.