runas.exe will not run Firefox as the user you expect when you have other Firefox instances open

RESOLVED INVALID

Status

()

Toolkit
Startup and Profile System
RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: Martin Woodward, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Firefox is nice and tries to only have one process.  An area where is should not is as follows.  You have Firefox running as a high privaledge user - however you want to run as a user with limited privaledges because you would like to visit a site that you are not sure about.  The windows command to run proceeses in the existint session with a different user credentials is "runas.exe".  If you type "runas /user:myLowAccessUsername firefox.exe" while an instance of firefox is running with the higher privaledges then you will get a new window come up that is actually running with the privaledges of the existing firefox process - however this fact is not obvious to the user doing "runas" and is not the expected result.

Reproducible: Always

Steps to Reproduce:
1. Run firefox.exe as an administrative user
2. With existing firefox.exe open - run firefox.exe as a low-privaledged user "runas /user:myUser firefox.exe"

Actual Results:  
Use process explorer to see that you have only one instance of the firefox.exe process and it is running with the initial (high) credentials.

Expected Results:  
There should be two processes, one for each of the crendentials used to start the firefox.exe command

The work-around is to close all existing firefox windows before opening the new one with different credentials - however it is easy to miss a window and be running as a different user than you expect.i
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 1

9 years ago
=> invalid
you must use -no-remote and a second profile to get a second instance of firefox to run.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.