Minefield can't load pages after you switch your network interface

RESOLVED INVALID

Status

()

P4
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: erappleman, Assigned: jimm)

Tracking

({qawanted, regression})

Trunk
Firefox 3
x86
Windows Vista
qawanted, regression
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007100418 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007100418 Minefield/3.0a9pre

Minefield can't load pages after you switch your network interface until you kill the process and restart the browser.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
*forgot the steps to produce.

1. Open Minefield while connected to a wireless or wired network.
2. Browse a bit.
3. Switch your network interface from wireless to wired or wired to wireless.
4. Try to browse, you can't.

You have to kill the process in the task manager and restart Minefield before you can browse again.
(Reporter)

Updated

11 years ago
Severity: normal → major
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Lucy has been able to reproduce this, so confirming and adding qawanted.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3? → blocking-firefox3+
Keywords: qawanted, regression
(Reporter)

Comment 3

11 years ago
Mike, what's your browser string?
I was hitting this really randomly, and mostly at the MV office.  I think I still have a log somewhere from when I was trying to troubleshoot it.  Biesi's guess was that putting it into offline mode and then back to online mode would work.  I've been using alpha 7 for a while and not hitting it, will switch back to nightlies and see if it comes up again.

Eric, did this start for you at any point? Would you be able to see if it does or doesn't happen in alpha 7 for you?
OK, so the log from Majken shows that the last thing that happens on the socket transport thread is a PR_Poll without a timeout. I would therefore suspect that this is similar to bug 213637, except that the poll never returns instead of returning immediately.

However, the code in question is basically the same on branch...
(Reporter)

Comment 6

11 years ago
majken, at least a week or two ago...

Comment 7

11 years ago
Easy to reproduce: 

* Connect to a wireless network
* Browse a bit
* Put computer/laptop in standby
* Wait a bit
* Wake up the computer/laptop
* Try to browse

It happens every time, simply closing firefox isn't enough, since the next time I start a process, it gives a message that a non-responding firefox is still running. I have to open taskmanager and kill it.
michael - would you be able to make a log of it? 

http://www.mozilla.org/projects/netlib/http/http-debugging.html

It probably won't attach here, but if you get one we can email it/put it up somewhere else and biesi can compare it to mine, see if it has any clues.

Comment 9

11 years ago
http://www.michaeleninneke.be/storage/log.txt

* I first visited tweakers.net
* then i want into standby
* after resuming, i tried searching with the integrated searchfield, and clicked a few bookmarks

I noticed however, that there is a connection made, but the screen doesn't change, and the statusbar just tells "Stopped".

Updated

11 years ago
Target Milestone: --- → Firefox 3 M11
more fun with network stacks for Jim!
Assignee: nobody → jmathies
Priority: -- → P3
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED

Updated

11 years ago
Priority: P3 → P4
Not blocking on this bug for final ship. Would take a safe enough patch if one comes through.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
(Assignee)

Updated

11 years ago
Keywords: qawanted
(Assignee)

Comment 12

11 years ago
I was just testing this with Beta 4 and a laptop running Vista on a wireless network. I tried to scenarios, a full hibernation/resume, and a sleep/wake. In both cases I was not able to reproduce. Can anyone else confirm what I'm seeing currently?

Steps -
1) boot, connect to a wireless network
2) open firefox beta 4, search for 'firefox' using the search bar
3) start -> hibernate
4) wait for the computer to finish, then power back up and wait for a wireless network connection to be established
5) search for 'twitter' in the search bar

result: the search results come up for 'twitter'

or

1) boot, connect to a wireless network
2) open firefox beta 4, search for 'firefox' using the search bar
3) close the lib on the laptop and wait for the computer to fully sleep
4) open the lid and wait for a wireless network connection to be established
5) search for 'twitter' in the search bar

result: the search results come up for 'twitter'
(Assignee)

Updated

11 years ago
Keywords: qawanted
(Assignee)

Updated

11 years ago
Target Milestone: Firefox 3 beta3 → Firefox 3
(Assignee)

Comment 13

11 years ago
marking as invalid, if anyone is still experiencing this, please re-open and I'll take another look.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.