Convert from reference by value to reference by ID - target_milestone

RESOLVED DUPLICATE of bug 287337

Status

()

Bugzilla
Database
--
enhancement
RESOLVED DUPLICATE of bug 287337
11 years ago
11 years ago

People

(Reporter: Kevin Benton, Assigned: Kevin Benton)

Tracking

Details

(Assignee)

Description

11 years ago
Convert target_milestones from using a composite primary key to a non-contextual ID, then re-add product_id and value as a UNIQUE constraint on the milestones table.  After that, change the bugs.target_milestone field to use that new primary key.

Comment 1

11 years ago
Custom fields store their ID in the bugs table, exactly the reason why mkanat wants to convert the TM into a custom field.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 4.0 → ---
Duplicate of bug: 287337
You need to log in before you can comment on or make changes to this bug.