If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Context menus for status bar icons should behave like regular context menus

RESOLVED WORKSFORME

Status

()

Firefox
Menus
--
minor
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Dennis Jacobfeuerborn, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007100504 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007100504 Minefield/3.0a9pre

When I right-click on the status bar icon for the greasemonkey or adblock plus extensions the context menu appears and then disappears again immediately making their behavior inconsistent with the behavior of other context menus in Firefox.

This does not happen with the Firebug extension. I believe the reason this happens is because when the context menu for the two offending extensions pops up the mouse is over an radio-button entry of the menu and that seems to confuse the event mechanism of Firefox a little leading it to use the right-click event twice not only for opening the menu but also for un-/checking the radio element and then dismissing the menu. Since when opening the context menu for Firebug the mouse is not placed on a radio element entry the menu stays open as it should.

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk

Updated

10 years ago
Severity: normal → minor
Can you try to create a new profile, install one of problematic extensions and test this bug?
(Reporter)

Comment 2

10 years ago
Creating a new profile was not necessary and the extension menus no longer show this problematic behavior in recent FF builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.