[Breakpad] Failed to submit crash report

RESOLVED FIXED

Status

()

Toolkit
Crash Reporting
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: John J. Barton, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8) Gecko/2007091216 GranParadiso/3.0a8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8) Gecko/2007091216 GranParadiso/3.0a8

FF 3.0a8 crashes on the first run after rebuilding Firebug several times today. (The second time it runs fine, maybe some registry building bug?).  Each time I get a pop-up dialog "Failed to submit crash report" or something similar. Nothing in Pending folder, no new entry in submitted folder.

Reproducible: Always

Steps to Reproduce:
1. I don't know how you reproduce this because the error message give zero information about why it failed.  
2.
3.


Expected Results:  
What I expected was a useful error message.  Honestly no popup dialog is much better than one that says something stupid and makes be click on "Ok" when its not ok.
Component: General → Breakpad Integration
Product: Firefox → Toolkit
QA Contact: general → breakpad.integration
Version: unspecified → Trunk

Comment 1

11 years ago
(In reply to comment #0)

> What I expected was a useful error message.  Honestly no popup dialog is much
> better than one that says something stupid and makes be click on "Ok" when its
> not ok.
> 

Very much agreed. This pops up out of the blue and contains no useful information whatsoever. The only purpose it serves right now is to confuse the unsuspecting user.

Not sure if this qualifies as a blocker per-se but it should be fixed for Firefox 3 (and at least get the "useless-UI" keyword).
Related: bug 399341.

We could remove the "failed to submit crash report" dialog entirely, if you'd like.  I agree that it's not terribly helpful.  Once that patch lands, and we have the submit.log file, you will be able to see if your crash report submitted successfully or failed.  I'm not willing to put the failure reason on the error dialog, since that just screams "random programmer information" to me, and it's not going to help most people.

Ted: What is the status of the submit.log file being landed?  Also, if I have a bunch of reports on Vista that failed, will they eventually end up on the submitted folder?
Marcia: the submit.log landed a while ago, it's in the Crash Reports folder.  Right now we don't resubmit reports that failed to send, that's bug 378528.
This bug report isn't useful.  We're going to get rid of the dialog in bug 404855, and we already added the log file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

10 years ago
Hey, I took the time to report this and in the end the UI was changed to remove the dialog.  Instead of "incomplete" and "isn't useful", I'll assume "thanks it's fixed now".
Resolution: INCOMPLETE → FIXED
The dialog hasn't been changed yet.  I don't consider your report useful, but you're free to use whatever resolution you want here.
You need to log in before you can comment on or make changes to this bug.