Bold characters garbled in some fonts from ttf-freefont

RESOLVED DUPLICATE of bug 401988

Status

()

RESOLVED DUPLICATE of bug 401988
11 years ago
11 years ago

People

(Reporter: smontagu, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Created attachment 283892 [details]
Reduced testcase

Since the checkin of bug 362682, many of the language names in bold in the URL come out as garbage. As a rule, these are the ones that appeared as missing-glyph symbols before bug 362682, so this is not exactly a regression...
(Reporter)

Comment 1

11 years ago
Created attachment 283893 [details]
Screenshot of test case
(Reporter)

Comment 2

11 years ago
I removed the ttf-freefont package and no longer see this.
Summary: Bold characters garbled in some fonts → Bold characters garbled in some fonts from ttf-freefont
(Reporter)

Updated

11 years ago
Duplicate of this bug: 406289

Comment 4

11 years ago
Created attachment 294957 [details]
screen capture of this problem in Firefox 3 beta 2

Added screen capture of this problem. I have this problem in FF 3 beta 2.
To reproduce: visit http://www.bbc.co.uk/tamil/

Updated

11 years ago
Duplicate of this bug: 412285
Attachment 296977 [details] shows that it happens for Arabic too, in bold and/or italic.

Comment 7

11 years ago
And do these fonts work correctly in say gedit?

Updated

11 years ago
Depends on: 401988
Fixed in 401988.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401988
You need to log in before you can comment on or make changes to this bug.