Closed Bug 398900 Opened 12 years ago Closed 11 years ago

UI details from mail mode are not remembered after switch to Calendar mode and back

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Aureliano, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Lightning 0.7

I use Thunderbird (build Id: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.6) Gecko/20070728 Thunderbird/2.0.0.6 ID:2007072817) and Lightining (build Id 0.7-it).
If I ckick on calendar tab when I have a TB folder with messages grouping by 'G' with node "Today","Yesterday",... expanded, when return to messages pane (clicking  mail tab) my nodes of groupe by 'G' they are collapsed.


Reproducible: Always

Steps to Reproduce:
1.Grouping a folder messages with order 'G' and expand the 4 nodes ("Today","Yesterday", "Last week" and "Old mail")
2.click on calendar tab
3.click on mail tab
Actual Results:  
The nodes ("Today","Yesterday", "Last week" and "Old mail") not remember the status expanded.

Expected Results:  
The nodes ("Today","Yesterday", "Last week" and "Old mail") should be remember the status expanded.
Summary: No store expanded status → No remeber expanded status
Confirmed with lightning 2007100605
Status: UNCONFIRMED → NEW
Ever confirmed: true
In general, it would be nice if "everything" in mail mode is remembered, including which message is selected in the thread pane and the position of the scrollbar in the message pane.  This would be nice, for example, when I'm reading a long email from Bugzilla about Lightning and I want to temporarily switch to calendar mode to verify the bug's report and then return to mail mode and quickly continue to read the rest of the email.
Summary: No remeber expanded status → UI details from mail mode are not remembered after switch to Calendar mode and back
OS: Windows XP → All
Hardware: PC → All
Doesn't apply to latest Lightning 0.8pre (build 2008022218)
Attached image screenshot - before
Thunderbird version 2.0.0.13pre (20080222), Lightning 0.8pre 20080222, WinXP, fresh profile

I'm still seeing this bug, but only for locally created folders. Here's a screenshot containing 3 emails, one of which is threaded, before I switch to calendar view.
Attached image screenshot - after
See the red arrow. The UI looks like this after I change to Calendar view and back to Mail view again.

The previously expanded thread in the folder is now "automatically" collapsed.

Tested that this occurs only in locally created folders and not for IMAP folders.
also applies to the new 0.8RC1 (windows, build 2008030620)
Still happens in Lightning 0.8 (German) with Thunderbird 2.0.0.12.
Also occurs in IMAP folders.
But in contrast to the behaviour described by ulysse@email.it, if you have a mail selected in the message pane before switching to calendar mode, the group of that selected mail remains eypanded when going back to mail mode. Only the other groups are collapsed.
(In reply to comment #7)
> Still happens in Lightning 0.8 (German) with Thunderbird 2.0.0.12.
> Also occurs in IMAP folders.
> But in contrast to the behaviour described by ulysse@email.it, if you have a
> mail selected in the message pane before switching to calendar mode, the group
> of that selected mail remains eypanded when going back to mail mode. Only the
> other groups are collapsed.

Yes I can confirm your detail: the group of that selected mail remains eypanded when going back to mail mode. Only the other groups are collapsed.

Ciao

Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.16) Gecko/20080708 Lightning/0.8 Thunderbird/2.0.0.16 ID:2008070808
Duplicate of this bug: 495095
Aureliano, Gary (and others), what is the situation using a Thunderbird 3 nightly and Lightning 1.0pre?
With 3.0b3pre, I dont have the same issue because integration of lightining into TB it is changed.

But remain ever a similar problem that I have filled in the past #387098 and #387098
(In reply to comment #11)
> But remain ever a similar problem that I have filled in the past #387098 and
> #387098

What is the second issue... really? ;)
Ops... #488641

:D
Aureliano, so we can resolve this bug because the switch from mode to tab mode fixed the issue?
I don't think this bug is completely fixed yet.  For example, if you scroll the message pane in mail mode, switch to calendar mode, then switch to mail mode, the message pane has returned to the top of the email instead of remembering the scrollbar position.
(In reply to comment #14)
> Aureliano, so we can resolve this bug because the switch from mode to tab mode
> fixed the issue?

I agree, using TB 3.xpre and lightning 1.0pre. I post this bug when I use TB 2 and lightining 0.8.

For me is resolved. 
I can't say if it is the same thing for 2.x users.
(In reply to comment #15)
> I don't think this bug is completely fixed yet.  For example, if you scroll the
> message pane in mail mode, switch to calendar mode, then switch to mail mode,
> the message pane has returned to the top of the email instead of remembering
> the scrollbar position.

Confirmed. In effect return at the top last message focused.
(In reply to comment #17)
> (In reply to comment #15)
> > I don't think this bug is completely fixed yet.  For example, if you scroll the
> > message pane in mail mode, switch to calendar mode, then switch to mail mode,
> > the message pane has returned to the top of the email instead of remembering
> > the scrollbar position.
> 
> Confirmed. In effect return at the top last message focused.

...but in my opinion not is a wrong behavior.
(In reply to comment #15)
> I don't think this bug is completely fixed yet.  For example, if you scroll the
> message pane in mail mode, switch to calendar mode, then switch to mail mode,
> the message pane has returned to the top of the email instead of remembering
> the scrollbar position.

Pete, please file a new bug if this is true for Lightning 1.0pre, BUT I suspect this is a Thunderbird issue because we now have a tab model provided by Thunderbird and no mode-logic specifically developed for Lightning.


(In reply to comment #16)
> For me is resolved. 
> I can't say if it is the same thing for 2.x users.

Resolving as WORKSFORME per comment#16 because the original issue is not reproducible. For any other issues a separate bug should be filed!
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
(In reply to comment #19)
> I suspect
> this is a Thunderbird issue because we now have a tab model provided by
> Thunderbird and no mode-logic specifically developed for Lightning.

Agreed.  However, I don't plan on filing a Thunderbird bug in the near future because they're making so many changes right now to the tab stuff in the betas.  Maybe it will be magically fixed by the time they release TB 3.0.
You need to log in before you can comment on or make changes to this bug.