JS exception dragging image

RESOLVED DUPLICATE of bug 393627

Status

()

Core
Drag and Drop
RESOLVED DUPLICATE of bug 393627
11 years ago
10 years ago

People

(Reporter: Josh Aas, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Using current trunk debug build, repro steps:

1. Set home page to "http://www.mozilla.org/projects/minefield/"
2. Open browser
3. Drag Minefield bomb icon in top-left of page
4. See exception in console

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'Component is not available' when calling method: [nsIHandlerService::fillHandlerInfo]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "<unknown>"  data: no]
************************************************************

Not all images produce the exception, just some.
(Reporter)

Comment 1

11 years ago
Actually, I think this happens with all images. What I thought was an image not producing the  exception was not an image.
Flags: blocking1.9?
This sounds like yet another instance of bug 393627.
Indeed. Probably called via nsTransferableFactory::Produce which calls nsOSHelperAppService::GetFromTypeAndExtension which calls nsHandlerService::fillHandlerInfo.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393627
(Reporter)

Updated

10 years ago
Flags: tracking1.9?
You need to log in before you can comment on or make changes to this bug.