Untranslated strings in Tools -> Options -> Feeds

RESOLVED FIXED

Status

Mozilla Localizations
fa / Persian
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Mana Ghavifekr, Assigned: Away for a while)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fa-IR; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fa-IR; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Untranslated strings:

"Show me a preview and ask me which Feed Reader to use"
"Subscribe to the feed using:"

Reproducible: Always
(Assignee)

Comment 1

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; fa-IR; rv:1.8.1.7)
Gecko/20070914 Firefox/2.0.0.7

Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

10 years ago
Blocks: 285718
Mana, thank you for testing and bug reporting.

Ehsan, thank you too for confimations, but you don't have to confirm these obvious reports.

And, please use bug Persian-Fx2.0 as the tracker, not the main Persian one, as these are some small l10n bugs, and there are a lot of people on the CC list of Persian tracker.

BTW are you going to send patches?  I'm a little busy these days with my thesis, so it's a great help if you can do the patch too.
(Assignee)

Comment 3

10 years ago
(In reply to comment #2)
> Mana, thank you for testing and bug reporting.
> 
> Ehsan, thank you too for confimations, but you don't have to confirm these
> obvious reports.

Sorry about that.  I was following the usual practice in other components of the bugzilla (I'm new to the l10n/fa component).

> And, please use bug Persian-Fx2.0 as the tracker, not the main Persian one, as
> these are some small l10n bugs, and there are a lot of people on the CC list of
> Persian tracker.

Oops!  Should I go ahead and change the dependencies for the new bugs (which causes even more emails sent to the CC's) or specify the correct dependencies on future bugs?

> BTW are you going to send patches?  I'm a little busy these days with my
> thesis, so it's a great help if you can do the patch too.

Yes, I am.  I think I'll get to work on the patches by the end of this week.  What is the necessary workflow on getting the l10n bugs fixed?  Should I ask for your (or someone else's) review and then request a checkin (like patches for other parts of the mozilla code base)?

By the way, now that I've turned this bug into a forum, what address should I watch to get an email on all of the new bugs in a component in Bugzilla (for example, l10n/fa)?

Thanks!
Assignee: behnam → ehsan.akhgari
> 
> Sorry about that.  I was following the usual practice in other components of
> the bugzilla (I'm new to the l10n/fa component).

No problem.  I just mentioned because it just a waste of time.

> Oops!  Should I go ahead and change the dependencies for the new bugs (which
> causes even more emails sent to the CC's) or specify the correct dependencies
> on future bugs?

Please set Persian-Fx2.0 for current and new ones.

> Yes, I am.  I think I'll get to work on the patches by the end of this week. 
> What is the necessary workflow on getting the l10n bugs fixed?  Should I ask
> for your (or someone else's) review and then request a checkin (like patches
> for other parts of the mozilla code base)?

That's great, thanks. :)

I don't wanna get it hard.  I'm gonna review and check-in patches straight, and just notice you about the changes in review.

> By the way, now that I've turned this bug into a forum, what address should I
> watch to get an email on all of the new bugs in a component in Bugzilla (for
> example, l10n/fa)?

Well, it's not possible right now.  I'm gonna request a fake maintainers address (ie. l10n-fa-maintainers@mozilla.bugs) for the default QA, then you can just set a watch on this address.
(Reporter)

Comment 5

10 years ago
(In reply to comment #2)
> Mana, thank you for testing and bug reporting.
You're welcome Behnam. Wowww these communications are very cool, I love it :D 
Good luck to you Ehsan! :) 
(Assignee)

Updated

10 years ago
No longer blocks: 285718
(Assignee)

Updated

10 years ago
Blocks: 349207
(Assignee)

Comment 6

10 years ago
(In reply to comment #4)
> > Oops!  Should I go ahead and change the dependencies for the new bugs (which
> > causes even more emails sent to the CC's) or specify the correct dependencies
> > on future bugs?
> 
> Please set Persian-Fx2.0 for current and new ones.

Done.

> > Yes, I am.  I think I'll get to work on the patches by the end of this week. 
> > What is the necessary workflow on getting the l10n bugs fixed?  Should I ask
> > for your (or someone else's) review and then request a checkin (like patches
> > for other parts of the mozilla code base)?
> 
> That's great, thanks. :)
> 
> I don't wanna get it hard.  I'm gonna review and check-in patches straight, and
> just notice you about the changes in review.

Cool!  By the way, I'd like to help if there are other things requiring work, besides translation of the UI strings...

> > By the way, now that I've turned this bug into a forum, what address should I
> > watch to get an email on all of the new bugs in a component in Bugzilla (for
> > example, l10n/fa)?
> 
> Well, it's not possible right now.  I'm gonna request a fake maintainers
> address (ie. l10n-fa-maintainers@mozilla.bugs) for the default QA, then you can
> just set a watch on this address.

That'd be nice.  Is there any bug on this issue which I can watch to track the progress?
> Cool!  By the way, I'd like to help if there are other things requiring work,
> besides translation of the UI strings...

We've done everything we possibly could for the 1.8 branch.  I don't think anything more than translation and maybe some small xul/css patches would get in the branch.  The best thing to do is testing gecko1.9/firefox3.0 and report problems asap.

> That'd be nice.  Is there any bug on this issue which I can watch to track the
> progress?

bug 399217.
(Assignee)

Comment 8

10 years ago
Created attachment 284530 [details] [diff] [review]
Translate two strings and two access keys

The patch to translate the strings.

This patch is tested against FF 2.0.0.7.
Attachment #284530 - Flags: review?(behnam)
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
Comment on attachment 284530 [details] [diff] [review]
Translate two strings and two access keys

I translated liveBookmarks.label and chooseApplication.*.

Please note that "خوردخوان" has no Space nor ZWNJ.  We made it based on similar words, ie. Card-Reader ("کاردخوان").
Attachment #284530 - Flags: review?(behnam) → review+
Checking in browser/chrome/browser/preferences/feeds.dtd;
/l10n/l10n/fa/browser/chrome/browser/preferences/feeds.dtd,v  <--  feeds.dtd
new revision: 1.2; previous revision: 1.1
done
Checking in browser/chrome/browser/preferences/feeds.properties;
/l10n/l10n/fa/browser/chrome/browser/preferences/feeds.properties,v  <--  feeds.properties
new revision: 1.2; previous revision: 1.1
done
Checking in browser/chrome/browser/preferences/tabs.dtd;
/l10n/l10n/fa/browser/chrome/browser/preferences/tabs.dtd,v  <--  tabs.dtd
new revision: 1.2; previous revision: 1.1
done
Checking in browser/chrome/browser/safebrowsing/phishing-afterload-warning-message.dtd;
/l10n/l10n/fa/browser/chrome/browser/safebrowsing/phishing-afterload-warning-message.dtd,v  <--  phishing-afterload-warning-message.dtd
new revision: 1.2; previous revision: 1.1
done
Checking in browser/chrome/browser/safebrowsing/report-phishing.dtd;
/l10n/l10n/fa/browser/chrome/browser/safebrowsing/report-phishing.dtd,v  <--  report-phishing.dtd
new revision: 1.2; previous revision: 1.1
done
Checking in browser/chrome/browser-region/region.properties;
/l10n/l10n/fa/browser/chrome/browser-region/region.properties,v  <--  region.properties
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/chrome/global/intl.properties;
/l10n/l10n/fa/toolkit/chrome/global/intl.properties,v  <--  intl.properties
new revision: 1.2; previous revision: 1.1
done

Some translations and fixes for Bugs 398998, 398999, 399000, 399001, and 399586, by Ehsan Akhgari
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

10 years ago
Mass edit of the QA Contact --> <persian.fa@localization.bugs>
QA Contact: nobody → persian.fa
You need to log in before you can comment on or make changes to this bug.