Suite crashes if net connection is severed during send

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Sune Mølgaard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4

I connect to my uni's VPN server via vpnc, and sometimes the connection drops.

I was trying to send a mail to staff, and noticed that the connection was bad.

I issued vpnc-disconnect, and seamonkey crashed.

Reproducible: Didn't try

Steps to Reproduce:
1. Connect to some VPN server via vpnc.
2. Let the connection go bad (no throughput).
3. Try to send an email.
4. While seamonkey is trying to send (and can't, due to bad connection), sever the VPN connection with vpnc-disconnect.
5. Watch seamonkey die...
Actual Results:  
Total crash

Expected Results:  
Prompt informing that sending failed, with ability to resend, when connection is up again...

Comment 1

10 years ago
Can you test if this also happens with a trunk build from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/ ?
(Reporter)

Comment 2

10 years ago
As a matter of fact, I ran into the same situation (network-wise) again, however this time seamonkey didn't crash, leading me to believe that either the crash was unrelated, or else, it is at least non-reproducible.

I will note, however, that the latest official seamonkey (1.1.4) does seem to crash a lot at my home machine. Again, this is nonreproducible, as for a number of days, the browser would have crashed when I returned from uni or got up in the morning, but for the past few days, it has stayed up. I have no idea how to diagnose it, so I leave it as an anecdotal remark rather than filing a bug.

Best regards,

Sune

Comment 3

10 years ago
Resolving as WFM, reopen if get more details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.