Firefox eBay Edition download/setup files are non-existent

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
6 years ago

People

(Reporter: stephend, Assigned: reed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
1. Load http://en.www.mozilla.com/en/add-ons/ebay/ using Safari 3.0.3 on Windows
2. Click on the green Download Firefox eBay Edition image/link

Actual Results:

http://releases.mozilla.com/ebay/2.0.0.3-online/win32/en/Firefox%20Setup%202.0.0.6.exe is served, but 404s...

Expected Results:

User should be served the appropriate 2.0.0.6 (or 7, depending on when the partner builds are updated) build for their operating system/platform, which is packaged with the eBay customizations.
(Reporter)

Updated

11 years ago
Summary: Firefox eBay Edition setup files are non-existent → Firefox eBay Edition download/setup files are non-existent
correct link should be http://releases.mozilla.com/ebay/2.0.0.3-online/win32/en-US/Firefox%20Setup%202.0.0.6.exe 

(the -US) is missing in /win32/en ..
AFAIK www.mozilla.com/en/ is a symbolic link to www.mozilla.com/en-US/ so the code on the en-US download page should be changed to replace the $lang variable by en-US even if it is called from the /en/ folder.

This said, I have never seen the mozilla.com/en/ URLs used anywhere so before making this change to the code, we should know if the ebay page called from /en/ should propose an en-US firefox-ebay or en-GB. Like, is this url used by ebay.co.uk?
(Assignee)

Updated

11 years ago
Assignee: nobody → reed
(Assignee)

Comment 3

11 years ago
clouserw: This is another case where en.www.mozilla.com causes problems. Can we track down what is causing people to get 'en' over 'en-US' and fix that? Otherwise, I'd like to add a hack in to force people that go to 'en' over to 'en-US'.
Assignee: reed → nobody
People would get en over en-US if en was in their accept-lang headers first.  And Pascal is correct, it's just a symlink to en-US.
(Assignee)

Comment 5

11 years ago
(In reply to comment #4)
> People would get en over en-US if en was in their accept-lang headers first. 
> And Pascal is correct, it's just a symlink to en-US.

Yeah, but this breaks stuff that depends on $lang, such as these eBay pages.
Depends on: 402821
(Assignee)

Updated

11 years ago
Duplicate of this bug: 407283
(Assignee)

Updated

11 years ago
Assignee: nobody → reed
(Assignee)

Comment 7

11 years ago
Fixed in r8798 on trunk. Will tag for stage and production now, as soon as I figure out the new order of things.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

11 years ago
Verified FIXED with Safari 3.0.4 on Windows XP SP 2.
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.