browser.tabs.loadBookmarksInBackground problems, this bug is no longer applicable

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
10 years ago
7 years ago

People

(Reporter: mmortal03, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100110 Firefox/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100110 Firefox/3.0a6pre

browser.tabs.loadBookmarksInBackground set to true isn't working anymore for middle clicking on folders of bookmarks.  It works for single bookmarks but not for bookmark folders.

Reproducible: Always

Steps to Reproduce:
1. Set browser.tabs.loadBookmarksInBackground to true.
2. Middle-click on a folder containing multiple bookmarks

Actual Results:  
The new tabs open in the foreground.

Expected Results:  
The new tabs open in the background.
With browser.tabs.loadFolderAndReplace to false this worked correctly before the patch of bug 175124 was checked in on 2 Sep 2007.
Blocks: 175124
Component: Menus → Places
Flags: blocking-firefox3?
Keywords: regression
QA Contact: menus → places
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395024
(Reporter)

Comment 3

10 years ago
Can you explain why this is a duplicate of that bug?  I read through that bug report, and that option deals with tabs replacing other tabs or not.  This option, and bug, deals with tabs that are first opened, but regardless of whether or not they replace other tabs, then take the focus or foreground.  browser.tabs.loadBookmarksInBackground should cover both one bookmark or multiple bookmarks being opened, and has nothing to do with tab replacement.  Now, if that other bug is a blocker of this one for some odd reason, then it should be set that way, but not as a duplicate of this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I also think this is not a dupe. This bug is about the focus behaviour, a clear regression. Bug 395024 is, if I understand it correctly, about the difference in replacing behaviour between middle click and the context menu option "Open All in Tabs". 
WONTFIX.  This was an intended change.

Bookmarks now respect the full set of modifiers like the rest of the UI, so Shift + middle click will open in the background.  I know this is a legacy pref, but now that we actually have support for the same modifiers as the rest of the UI it doesn't make sense to have a special pref for just the bookmarks, while back/forward/home/go etc don't respect that pref.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Flags: blocking-firefox3? → blocking-firefox3-
Resolution: --- → WONTFIX

Comment 6

10 years ago
see also:
Bug 226826 – xremote 'new-tab' doesn't honour browser.tabs.loadInBackground

Bug 263553 – keep browser in background (unfocused, unactivated) as new tabs are opened into it

(Reporter)

Comment 7

10 years ago
(In reply to comment #5)
> WONTFIX.  This was an intended change.
> 
> Bookmarks now respect the full set of modifiers like the rest of the UI, so
> Shift + middle click will open in the background.  I know this is a legacy
> pref, but now that we actually have support for the same modifiers as the rest
> of the UI it doesn't make sense to have a special pref for just the bookmarks,
> while back/forward/home/go etc don't respect that pref.
> 

That isn't true.  Single bookmarks act differently than folders of bookmarks when middle-clicking here, so regardless of whether or not you guys want to remove that preference, which I don't care one way or the other about, it is either single bookmarks or folders of bookmarks that are acting contrary to the rest of the UI.  I would guess that it is folders of bookmarks that are acting improperly, because I also have browser.tabs.loadInBackground option set to true.

I have edited the title as such.


(In reply to comment #6)
> see also:
> Bug 226826 – xremote 'new-tab' doesn't honour browser.tabs.loadInBackground
> 
> Bug 263553 – keep browser in background (unfocused, unactivated) as new tabs
> are opened into it
> 

The first bug deals with loadDivertedInBackground, and also deals with links, not bookmarks, so it isn't the same bug.

The second bug isn't describing the behavior here at all, but is an interesting one.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: browser.tabs.loadBookmarksInBackground set to true isn't working anymore for middle clicking on folders of bookmarks. → browser.tabs.loadInBackground set to true isn't working anymore for middle clicking on folders of bookmarks.

Comment 8

10 years ago
Never said it was the same bug, but it also deals with tabbed browsing and how links (or bookmarks) open. Thought it would help in some way. Thanks.
This is a WONTFIX, if there is a bug regarding apparently inconsistency between middle click on bookmarks and bookmark folders, please file that.  The pref is unsupported and will be stripped from firefox.js.  Please email me rather than reopening this bug.

Middle click on a bookmark appends that bookmark as a new bookmark.
Middle click on folders should append that set of bookmarks and select the first one.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 10

10 years ago
That is what this bug IS.  I said that I changed the title to clarify it.  Man you guys are WONTFIX happy.  You aren't even reading what I have written.  You can reopen it if you realize what I am saying.  It isn't about browser.tabs.loadBookmarksInBackground now. 
(Reporter)

Comment 11

10 years ago
Yes, Middle click on a bookmark appends that bookmark as a new bookmark.
Yes, Middle click on folders should append that set of bookmarks, but No, it should NOT just select the first one.  It should follow browser.tabs.loadInBackground.
If you want to invert the behaviour to load in background, Shift+Middle Click does that (or Accel+Shift+Click, for those without middle buttons).

browser.tabs.loadInBackground has explicitly controlled the content area clicks.  It has never been part of the UI/chrome pref controls.
(Reporter)

Comment 13

10 years ago
Nope, Shift->Middle Clicking on a folder replaces the current tab with the first link, and then opens the rest in the background, so it doesn't function like Shift->Middle Clicking on an individual bookmark. I have renamed the description as such.  Please reopen this bug for that purpose.  I am going to email you a proposal regarding the other issue, Mike.
Summary: browser.tabs.loadInBackground set to true isn't working anymore for middle clicking on folders of bookmarks. → shift->middle clicking on a folder of bookmarks should not replace the currently existing tab unless it is blank, if browser.tabs.loadFolderAndReplace is set to false
(Reporter)

Updated

10 years ago
Summary: shift->middle clicking on a folder of bookmarks should not replace the currently existing tab unless it is blank, if browser.tabs.loadFolderAndReplace is set to false → browser.tabs.loadBookmarksInBackground problems, this bug is no longer applicable)
(Reporter)

Comment 14

9 years ago
This bug is applicable whether or not browser.tabs.loadBookmarksInBackground exists anymore.  The behavior is not consistent within the interface, WITHOUT THE OPTION, as described in my previous post.
Summary: browser.tabs.loadBookmarksInBackground problems, this bug is no longer applicable) → browser.tabs.loadBookmarksInBackground problems, this bug is no longer applicable
(Reporter)

Comment 15

9 years ago
I have created Bug 400491 to address the specific inconsistency described above, so as to both clarify the problem and leave no confusion or ambiguity that this bug report should remain closed.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.