Crash when clicking on toolbarbutton with type="menu"

RESOLVED WORKSFORME

Status

Toolkit Graveyard
XULRunner
--
critical
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: Daniel Kirsch, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Bug Flags:
blocking1.9 -

Details

Attachments

(1 attachment)

581 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a9pre) Gecko/2007100911

When I click on a xul:toolbarbutton element with type="menu" XULRunner 2007100911 crashes immidiately.

Reproducible: Always

Steps to Reproduce:
Use the following code to reproduce

<toolbarbutton type="menu">
  <menupopup>
    <menuitem label="foo" />
    <menuitem label="bar" />
  </menupopup>
</toolbarbutton>
(Reporter)

Comment 1

10 years ago
Created attachment 284275 [details]
XUL Testcase
(Reporter)

Updated

10 years ago
Flags: blocking1.9?
Keywords: testcase
Version: unspecified → Trunk
(In reply to comment #0)
> Gecko/2007100911

Bug 399210, and you just need to update to an hour later, no?
(Reporter)

Comment 3

10 years ago
Seems to be the same. I don't know how to update to "an hour later". That's the latest build I've found. I'll recheck that within the next days.

Comment 4

10 years ago
Not blocking on this without an update.
Flags: blocking1.9? → blocking1.9-
(Reporter)

Comment 5

10 years ago
Seems to work again with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9b2pre) Gecko/2007111510

Comment 6

9 years ago
WFM per comment 5.
Please reopen if you still see thei problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.