double click fires on mouse down, how does this match the spec

RESOLVED DUPLICATE of bug 968265

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 968265
11 years ago
3 months ago

People

(Reporter: Michael Buckley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

I was doing something with ondbclick and noticed that it fires on the mouse down of the second click.  The spec has this to say

"The ondblclick event occurs when the pointing device button is double clicked over an element. This attribute may be used with most elements."

Is just pushing the mouse down a click? Or is then releasing it to required to complete a "click".  I would think the down and up motion should be required to complete a "click".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Component: General → DOM: Events
Product: Firefox → Core
QA Contact: general → events

Comment 1

11 years ago
A *minimal* testcase would be great.
(I didn't test this yet at all, but click events are dispatched
in ESM during the posthandling of NS_MOUSE_BUTTON_UP)
(Reporter)

Comment 2

11 years ago
I might make a test case when I get time.  I am seeing the bug in MinimizeToTray extension I selected the double click to restore option.  The problem being that it fires on the mouse down of the second click, resulting in the mouse up restoring another tray item which is very annoying. 

Comment 3

3 years ago
Hallow. my Thunderbird under winXPsp3 behavies like described above:
at starting, or at some loading of CPU work on filters or local archive, every second single-mouse-click treats as double-clicking. so i cant`t just selects some messages - second click forces to open selected messages in their own tabs. it need to awaitng some time to prevent mouse click from accepting as double.

  Сведения о приложении

    Имя: Thunderbird
    Версия: 38.2.0
    User Agent: Mozilla/5.0 (Windows NT 5.1; rv:38.0) Gecko/20100101 Thunderbird/38.2.0
    Папка профиля: Показать папку

              (Локальный диск)
    ID сборки приложения: 20150813074416
    Включённые плагины: about:plugins
    Конфигурация сборки: about:buildconfig
    Использование памяти: about:memory

  Учётные записи почты и новостей
    account1:
      INCOMING: account1, , (none) Local Folders, plain, passwordCleartext

    account2:
      INCOMING: account2, , (imap) lavabit.com:993, SSL, passwordCleartext
      OUTGOING: lavabit.com:465, SSL, passwordCleartext, true

    account3:
      INCOMING: account3, , (imap) imap.yandex.ru:143, plain, passwordCleartext
      OUTGOING: smtp.yandex.ru:25, trySTARTTLS, passwordCleartext, true

    account4:
      INCOMING: account4, , (pop3) pop.yandex.ru:110, plain, passwordCleartext
      OUTGOING: pop.yandex.ru:25, trySTARTTLS, passwordCleartext, true

    account5:
      INCOMING: account5, , (pop3) pop.qip.ru:110, plain, passwordCleartext
      OUTGOING: smtp.pochta.ru:25, plain, passwordCleartext, true

    account6:
      INCOMING: account6, , (pop3) pop.qip.ru:995, SSL, passwordCleartext
      OUTGOING: smtp.newmail.ru:25, trySTARTTLS, passwordCleartext, true

    account7:
      INCOMING: account7, , (pop3) pop.mail.ru:995, SSL, passwordCleartext
      OUTGOING: smtp.mail.ru:25, plain, passwordCleartext, true

    account8:
      INCOMING: account8, , (pop3) pop.qip.ru:995, SSL, passwordCleartext
      OUTGOING: smtp.qip.ru:25, trySTARTTLS, passwordCleartext, true

    account10:
      INCOMING: account10, , (pop3) pop3.predanie.org:995, SSL, secure
      OUTGOING: smtp.gmail.com:465, SSL, passwordCleartext, true

    account11:
      INCOMING: account11, , (imap) imap.gmail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.gmail.com:465, SSL, passwordCleartext, true

    account12:
      INCOMING: account12, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

  Сообщения о падениях

  Расширения
    Test Pilot for Thunderbird, 1.3.9, true, tbtestpilot@labs.mozilla.com

  Важные изменённые настройки

    Имя: Значение

      accessibility.typeaheadfind.flashBar: 0
      browser.cache.disk.capacity: 358400
      browser.cache.disk.smart_size_cached_value: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      extensions.lastAppVersion: 38.2.0
      font.internaluseonly.changed: false
      gfx.blacklist.direct2d: 3
      gfx.blacklist.direct3d11angle: 3
      gfx.blacklist.dxva: 3
      gfx.blacklist.layers.direct3d10: 3
      gfx.blacklist.layers.direct3d10-1: 3
      gfx.blacklist.layers.direct3d11: 3
      gfx.blacklist.layers.direct3d9: 3
      gfx.blacklist.layers.opengl: 3
      gfx.blacklist.stagefright: 3
      gfx.blacklist.suggested-driver-version: 6.1400.1000.5218
      gfx.blacklist.webgl.angle: 3
      gfx.blacklist.webgl.msaa: 3
      gfx.blacklist.webgl.opengl: 3
      mail.openMessageBehavior.version: 1
      mailnews.database.global.datastore.id: bc907bc6-270e-411b-9950-010992e8dbc
      network.cookie.prefsMigrated: true
      network.predictor.cleaned-up: true
      places.database.lastMaintenance: 1446322007
      places.history.expiration.transient_current_max_pages: 53446
      places.history.expiration.transient_optimal_database_size: 28067430
      plugin.importedState: true

  Графика

      Описание видеокарты: Intel(R) 82865G Graphics Controller
      Код производителя: 0x8086
      Код устройства: 0x2572
      Объём видеопамяти: Unknown
      Драйвера видеокарты: ialmrnt5
      Версия драйвера: 6.14.10.4396
      Дата разработки драйвера: 9-20-2005
      Визуализатор WebGL: Заблокирован для вашей версии драйвера видеокарты. Попробуйте обновить ваш драйвер видеокарты до версии 6.1400.1000.5218 или более новой.
      Аппаратно ускоренные окна: 0. Заблокирован для вашей версии драйвера видеокарты. Попробуйте обновить ваш драйвер видеокарты до версии 6.1400.1000.5218 или более новой.

      AzureCanvasBackend: skia
      AzureSkiaAccelerated: 0
      AzureFallbackCanvasBackend: cairo
      AzureContentBackend: cairo

  JavaScript

  Инкрементальный GC: 1

  Поддержка доступности

    Активирована: 0
    Отключение поддержки доступности: 0

  Версии библиотек

      Ожидаемая минимальная версия
      Используемая версия

      NSPR
      4.10.8
      4.10.8

      NSS
      3.19.2 Basic ECC
      3.19.2 Basic ECC

      NSS Util
      3.19.2
      3.19.2

      NSS SSL
      3.19.2 Basic ECC
      3.19.2 Basic ECC

      NSS S/MIME
      3.19.2 Basic ECC
      3.19.2 Basic ECC
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 968265
You need to log in before you can comment on or make changes to this bug.