Text box fails when width exceeds 65535 pixels.

RESOLVED DUPLICATE of bug 257660

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 257660
11 years ago
11 years ago

People

(Reporter: Kevin Spiteri, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.4) Gecko/20060527 SUSE/1.5.0.4-1.9 Firefox/1.5.0.4
Build Identifier: version 2.0.0.6 (20070728)

If in the Thunderbird compose window I write a word long enough to exceed 65535 pixels width, the text at the beginning and end of the word is not rendered properly. This bug is evident when receiving an email with a long word as well.

Reproducible: Always

Steps to Reproduce:
1. Click "Write" to compose new message.
2. Write a very long word, copying and pasting works fine.
3. When 65535 pixels are reached, text at the beginning and ending of word is rendered incorrectly.

Comment 1

11 years ago
Screenshot?
(Reporter)

Comment 2

11 years ago
Created attachment 284721 [details]
The beginning of the line.

Part of the end of the line (abcdefghijklmnopqrstuvwxyz) is seen to be superimposed on the beginning of the line (ABCDEFGHIJKLMNOPQRSTUVWXYZ).
(Reporter)

Comment 3

11 years ago
Created attachment 284722 [details]
The end of the line.

Part of the beginning of the line (ABCDEFGHIJKLMNOPQRSTUVWXYZ) is seen to be superimposed on the end of the line (abcdefghijklmnopqrstuvwxyz).

Comment 4

11 years ago
Found the dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 257660
You need to log in before you can comment on or make changes to this bug.