Annoying redraw and flicker effects on pages with Flash contents under LINUX

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Ralph Moenchmeyer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-04-20)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.8.1.6) Gecko/20070730 SUSE/2.0.0.6-11.1 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.8.1.6) Gecko/20070730 SUSE/2.0.0.6-11.1 Firefox/2.0.0.6

When switching between pages with practically the same layout and contents Firefox (in its Linux version) redraws not only the Flash object area - instead it redraws DIV contents and images as well. 
This leads to very annoying flicker effects; on pages with Flash contents I regard FF under Linux almost unusable - in contrast to Opera (only Linux version) and Konqueror. 

For details see the attachments that I shall create - there you find test files and a test case description.  

Reproducible: Always

Steps to Reproduce:
1. Use a simple page with some Divs and images + a Flash objects. Copy the page and insert into each page a link to the other and vice versa.  
2. Switch between the pages by using the links. 
3. You will experience that not only the flash object is redrawn, but div contents and images, too. 
Actual Results:  
The described "Flicker" effect is not present in the Windows version of FF (at least not as long as you do not move your mouse directly after a link click) .
However, the effect is really massive and annoying for the Linux version. 
See the attachment for a comparison with other browsers!  

Expected Results:  
Smooth transitions between pages with basically the same layout and contents - despite an additional flash object (which also stays the same). The contents remaining constant in the pages should not be redrawn or reloaded! 

Konqueror and Opera behave much better on a Linux (KDE ) desktop - they only redraw the flash object area of a page. Everything else remains flickerfree, i.e. static for these other browsers. 
Surprisingly, Opera for Windows  is as bad as Firefox for Linux and redraws the whole page!
Firefox for Windows does not show the flicker effects - at least not in such a bad manner as the Linux version. 
Taking the examples of Opera and Konqueror for Linux it seems to be possible to improve FF substantially with respect to its handling of HTML pages with Flash contents.
(Reporter)

Comment 1

10 years ago
Created attachment 284313 [details]
PDF with a test case description and comparison of different browsers
(Reporter)

Comment 2

10 years ago
Created attachment 284315 [details]
Zip-container with test files  

A look at the contents of the  test files" test_1.html" and "test_2.html" together with a look at the previously sent pdf-file should allow for a simple test.

Comment 3

9 years ago
do you see this problem if you use flash version 10, and FF 3.x beta http://www.mozilla.com/en-US/firefox/all-beta.html

If not, please close with resolution set to worksforme.
Whiteboard: closeme 2009-04-20
@Reporter, we have not heard back from you in a while, so I am closing this bug as INCOMPLETE. You can reopen this bug if more information becomes available. Some helpful information you can provide us is found at http://quality.mozilla.org/bug-writing-guidelines. You should also use a recent version of Firefox, from http://www.getfirefox.com.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

9 years ago
Sorry that I could not react - I changed my job last month and did not have any time. 
I have a different HW and SW plattform now compared to the situation when I wrote the first bug report. I am running Opensuse 11.1 x86_64 with KDE 4.2 on a quite different machine now. I hope that this is irreleveant regarding the reasons for the bug ....  
  
Today, I tested again with Firefox 3.0.8 and both the latest 64 bit flash plugin from Adobe and the 32 bit standard plugin (vers. 10.0.22) delivered as a standard rpm from Opensuse.  
Result: The situation now is as it should be: For the test case (attachment to this report) I can confirm that only the area for the swf is redrawn, now  - everything else remains static - no flickers there, anymore.
  
So, I think the problem is resolved. The bug can be closed. Thanks for your efforts !
Resolution: INCOMPLETE → FIXED
I am glad your issue has been resolved, but that makes this bug WORKSFORME. FIXED is only for a bug that has had a known patch checked into the tree, which has not happened in this case.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.