font-family should not affect treatment of numeric character references

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: karlt, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Numeric character references should be treated as ISO 10646:
http://www.w3.org/TR/html4/charset.html#h-5.3.1.

If a font-family of a non-Unicode font is specified, then the character references are (incorrectly) interpreted as points in the fonts (system-selected?) cmap.

See attachment 282041 [details] from bug 397288 for a testcase.  This should show two y characters and one psi.

(Departure from the standard for the first y to be displayed as psi may be debatable, but even this is inconsistent with the resolution of bug 33127, or the effort to distinguish quirks mode in bug 195038.)

Comment 1

11 years ago
The behavior of handling symbol fonts is correct on Windows.  Other platforms should look and see what they do with fonts without Unicode character maps and match the behavior on Windows.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Duplicate of this bug: 352177
I disagree about this being invalid.  We used to do this only when nsFont::familyNameQuirks was true, which was when the family name came from a <font> tag and we were in quirks mode.
Status: RESOLVED → REOPENED
Flags: blocking1.9?
Resolution: INVALID → ---
Created attachment 284520 [details] [diff] [review]
proposal patch #1

This patch can fix this bug. But Stuart might not allow the changing.

Comment 5

11 years ago
the whole familyNameQuirks is completely busted.  we should remove it entirely from the tree.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INVALID

Comment 6

11 years ago
Also, if we really want to have this conversation, it should be in bug 33127 which I've reopened.
(Reporter)

Updated

11 years ago
Blocks: 399636
(Reporter)

Comment 7

10 years ago
Fixed by bug 399636.
No longer blocks: 399636
Depends on: 399636
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.