images spontaneously shrink or expand in small height div

VERIFIED FIXED in M18

Status

()

Core
Layout
P2
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: jlarsen, Assigned: Chris Waterson)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+] FIX IN HAND)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Try this code snippit
<html>
<body>

<div id="Layer1" style="position:absolute; height:7%">
<img src="http://www.mozilla.org/images/mozilla-banner.gif" height="100%">
</div>

</body></html>

Image slowly resizes itself sometimes to the proper size, sometimes it starts 
increasing its size to infinity. If you don't see it, try resizing the window. 
Works on Gifs Jpgs and Pngs (and any other I would assume) (works best with wide 
skinny pictures) the small the height the better chances of it occuring, 
sometimes occurs up to 20%
(Reporter)

Comment 1

18 years ago
Created attachment 8893 [details]
example

Comment 2

18 years ago
I have observed this behavior using 2000-05-19-08 Win Talkback on Windows 98,
except instead of expanding, the image shrinks.

Comment 3

18 years ago
updating component and owner.
Assignee: asadotzler → clayton
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: jelwell → petersen

Comment 4

18 years ago
Triage duty calls. Reassinging to pierre.
Assignee: clayton → pierre

Comment 5

18 years ago
Nice effect indeed! Reassigned to Layout. The problem may be triggered by some 
roundings in the calculations but still, we should not keep on resizing the image 
like that.
Assignee: pierre → clayton
Summary: images weirdness in small height div → images spontaneously shrink or expand in small height div

Comment 6

18 years ago
I did not mean to send it back to clayton.
Reassigned to waterson because buster is still the Most Doomed Person.
Assignee: clayton → waterson
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Updated

18 years ago
Keywords: correctness, nsbeta3
Target Milestone: M17 → M18
(Reporter)

Comment 7

18 years ago
Just wanted ot make a note, the bug has increased in annoyance, it now tried to
confirm its cache of the image on each resize.. creating a very annoying looking
thing, and contantly reconnecting to the website, I assume the website doesn't
like this either.
[nsbeta3+]
Whiteboard: [nsbeta3+]
(Assignee)

Updated

18 years ago
Priority: P3 → P2
(Assignee)

Comment 9

18 years ago
Created attachment 13477 [details] [diff] [review]
first try at a fix
(Assignee)

Comment 10

18 years ago
We get into a feedback loop when reflowing the image frame with a constrained
height but an auto width. (At least, with this test case.)

The above patch attempts to mitigate that by rounding to pixels.

If this approach seems reasonable, we'll need to do the same thing for images
with constrained width and auto height.
(Assignee)

Comment 11

18 years ago
Created attachment 13478 [details] [diff] [review]
if you liked that patch, you'll love this one.

Comment 12

18 years ago
this approach seems very reasonable.  r=buster, assuming you've done all the 
usual tests.
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+] FIX IN HAND
(Assignee)

Comment 13

18 years ago
fix checked in, r=buster,scc.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
Fixed in the Aug 30th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.