Closed Bug 399515 Opened 13 years ago Closed 12 years ago

Building with symlinked chrome links incorrect communicator.css for Classic theme

Categories

(SeaMonkey :: Build Config, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mnyromyr, Assigned: mnyromyr)

References

Details

Attachments

(1 obsolete file)

If you build trunk with 
  ac_add_options --enable-chrome-format=symlink
in your mozconfig file and run the resulting SeaMonkey using the Classic theme, the navigator throbber is missing and (main) toolbar button text is placed right of the icon instead of below.
This is due to the missing application of chrome://communicator/skin/brand.css, which in turn is caused by a wrong chrome://communicator/skin/communicator.css: the file currently used is from /toolkit (Pinstripe or Winstripe), but not /suite/themes/classic/communicator/communicator.css - the symlink into toolkit does not get overwritten... 
We need to enforce this.
Attachment #284538 - Flags: superreview?(neil)
Attachment #284538 - Flags: review?(neil)
Depends on: 399571
Comment on attachment 284538 [details] [diff] [review]
enforce using suite's communicator.css

Resolved by bug 399571, no?
Attachment #284538 - Flags: superreview?(neil)
Attachment #284538 - Flags: superreview+
Attachment #284538 - Flags: review?(neil)
Attachment #284538 - Flags: review+
Comment on attachment 284538 [details] [diff] [review]
enforce using suite's communicator.css

Yes, so it seems; at least the problem is gone and this patch not needed anymore.
Attachment #284538 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.