[FRM]<select> without <form> inaccesible from JavaScript

VERIFIED WONTFIX

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED WONTFIX
18 years ago
3 years ago

People

(Reporter: Vladimir-Corneliu Nicolici, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    2000051609

	If I use a <select name = "ObjectName"> without including it in a 
<form>, window . ObjectName (or FrameName . ObjectName) is not defined.

Reproducible: Always

Steps to Reproduce:
  1. Open the test case;
  2. Select option 2;
  3. Click OK.


Actual Results:  Only the first alert is displayed.


Expected Results:  A new alert should be displayed after the initial one.


It works in IE 4 - 5
(Reporter)

Comment 1

18 years ago
Created attachment 8896 [details]
Test case
(Assignee)

Updated

18 years ago
No longer blocks: 39953
Status: UNCONFIRMED → NEW
No longer depends on: 39953
Ever confirmed: true
(Assignee)

Comment 2

18 years ago
Moving to M17
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 3

18 years ago
This bug has been marked "future" because at this time it has been determined 
that it is not absolutely critical for RTM (Release To Manufacturing). If 
the reporter and anyone else believe it is necessary to fix this before shipping 
Seamonkey 1.0, please describe your issue in the bug. 
Target Milestone: M17 → Future

Comment 4

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
(Assignee)

Updated

18 years ago
Summary: <select> without <form> inaccesible from JavaScript → [FRM]<select> without <form> inaccesible from JavaScript
(Assignee)

Updated

18 years ago
Blocks: 14445
(Assignee)

Comment 5

18 years ago
will try to get this in

Comment 6

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Comment 7

17 years ago
Is the testcase for this bug valid? In Mozilla and NS4 I think you need to use
document.options.selectedIndex . Unless there are plans to put the named items
onto the window object...

Comment 8

17 years ago
scratch NS4 out of that comment but I think it still holds true for mozilla.

Comment 9

17 years ago
Created attachment 58861 [details]
testcase comparing what works in which browser
Excellent point.  In fact, select without a form *is* accessible in JavaScript
with document.getElementById().

So this bug boils down to "should form controls be accessible by name."  I have
heard we are deliberately not going to make form controls accessible with
document.name (I had another bug based on that), among other things, to keep
from polluting document's namespace.  It's  definitely not in the spec 
Attaching testcase show which methods work and which don't.  (Only
getElementById() works.)

I suggest WONTFIX unless there's another problem I'm not seeing.
Created attachment 58903 [details]
Testcase: Which Methods Can Access Select
Setting WONTFIX since we're not supporting document.controlname syntax to access
fields.  Reopen if there's something I missed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 13

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.