Thunderbird should have a pluggable storage engine to allow may different storage back-ends for mail, preferences

RESOLVED DUPLICATE of bug 402392

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 402392
10 years ago
4 years ago

People

(Reporter: hoffer53@gmail.com, Unassigned)

Tracking

({access, ecommerce})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 

If Thunderbird had a storage back-end that the community could create plugins for, we could create the Maildir, SQLite, or whatever plugin for storage that we wanted.  I would like to have a MySQL storage plugin so that it would be easy to create a webmail interface to T-Bird.  I would like to have a SQLite plugin to handle large mailboxes.  It would be cool to have both in use at the same time so that I could easily archive my emails on my system and keep the more pertinent emails in the webmail box.

I know that TBird already supports LDAP, but I think that it would be nice to have a pluggable address book.  This could accommodate an organization-wide address book as well as a private address book.  This could add to the idea of the TBird-webmail interface as well.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Additional bugs that seem to address this issue:
Bug 380897
Bug 290057
Bug 58308
Bug 364808
Bug 382876
(Reporter)

Updated

10 years ago
Keywords: access, ecommerce, mail3, mail4
(In reply to comment #0)
> I know that TBird already supports LDAP, but I think that it would be nice to
> have a pluggable address book.  This could accommodate an organization-wide
> address book as well as a private address book.  This could add to the idea of
> the TBird-webmail interface as well.

I believe the address book is already "pluggable" which would also allow different types of storage mechanism. If it isn't then it would be much better if you raised specific bugs on what is stopping you writing an extension than raising a general one which doesn't actually help anything.

If you need support with this, then the newsgroup mozilla.dev.apps.thunderbird on irc.mozilla.org is the place to ask.
Summary: Thunderbird should have a pluggable storage engine to allow may different storage back-ends for mail, preferences, and address books. → Thunderbird should have a pluggable storage engine to allow may different storage back-ends for mail, preferences
(Reporter)

Comment 2

10 years ago
Thanks for the info.  After looking through the mail code I did not see a way to program an extension for mail storage.  I have not looked at the address book code close enough to see how to write an extension for it.

Other than IRC, where might I find a central repository for Thunderbird specific extension programming?  Most programming info in Mozilla's domain seems to be targeted toward Firefox.

Since this is the wrong forum to bring up a topic such as this, I will mark the bug as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 3

6 years ago
You might find a backend plugin on AMO under thunderbird -- same place you find other types of plugins.   If there is non available, it might be because there is no place to plug them into.

Seems that's what the original author was asking for, yet it appears the bug was closed out due to there being no plugins available for the requested interface.

Examples of other software products with pluggable backends:
samba, -- multiple interfaces for backend user-db storage
squid, multiple plugs for logs, another group for backend storage, another for authentication... and maybe a few other areas.

The product getting the plugins has to take the first step in providing
a *modular*, interface.

Even Microsoft has done this with their search products -- publishing incomprehensible, ^h^h^h^h^h.. extremely detailed documents to comply with European law requiring they publish information on their interfaces...  (some of it is good, some looks like it might have been written under duress)...

(on reason I am commenting on this ancient bug is it cropped up in my search list before I filed a new bug).  If a pluggable backend had been made available 5 years ago, my bug might be a non-issue ...

Comment 4

6 years ago
see bug 402392 and https://wiki.mozilla.org/Thunderbird:Pluggable_Mail_Stores - Thunderbird 12 has a pluggable store backend for messages.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 402392
You need to log in before you can comment on or make changes to this bug.