`Save Page As' in File menu is inaccurate and inconsistent

VERIFIED DUPLICATE of bug 21282

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 21282
18 years ago
13 years ago

People

(Reporter: Paul LeBeau, Assigned: don)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
'Save Page As...' (M15) should be changed since it is not
always a page that is being saved.  For example, it could
be wav, mpg, pdf etc.

I suggest that it revert back to 'Save as...', or alternatively,
use 'Save Page As' for html/text etc and something like 'Save File
As' or 'Save Object As' for other file types.

Another suggestion would be to have 'Save <extension> as...'
but I suspect that would be a bit too ugly.

Comment 1

18 years ago
This seems like a no-brainer. Including anything between the `Save' and the `As' 
makes Mozilla inconsistent with most other popular apps. Just `Save As ...' is 
all that's necessary.

... Brendan?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

18 years ago
Are we talking about the file menu or context menus?  Context menus need "save 
page as" because "save as" is ambiguous.  For the file menu, on the other 
hand, "save as" does make more sense.

(side note: the context menu item should be disabled if something other than a 
webpage is being displayed and another menu item (such as "save image as") 
takes over the function.)

Comment 3

18 years ago
This bug was broken off bug 38389, which was talking about the item in the File 
menu. Resummarizing to clarify. CCing verah, 'coz it's a wording issue.
Summary: 'Save Page As' is bad menu item label → `Save Page As' in File menu is inaccurate and inconsistent

Comment 4

18 years ago
Yep, I agree.  The File menu should contain the generic "Save As" while 

context menus should reflect their context as much as possible (Save 

Page As, Save File As, etc.)



I'm not sure if there's an appropriate component choice for this type of 

bug, so I'm assigning it to Paul Hangas.  Paul?
Assignee: bdonohoe → hangas

Comment 5

18 years ago
Don, this bug is rather wordy, but the problem is simple.  The text of the menu 
item for "Save As..." should actually say "Save As...", currently is says Save 
Page As...
Assignee: hangas → don

Comment 6

18 years ago
dup of 21282.  Yes we should fix the menu item.


*** This bug has been marked as a duplicate of 21282 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
Verified dup.

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.