Page Info Form Current Values CheckBox Always On

RESOLVED INVALID

Status

()

defect
--
minor
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: matrix_encrypter, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

On page information, the HTML checkbox value displayed in the Form's current values is always equal to "on" when it should be set to "off"...

Reproducible: Always

Steps to Reproduce:
1. Load an HTML page with a checkbox
2. Tools -> Page Info, Forms tab
3. Lookup the HTML checkbox value
Actual Results:  
value = "on" even though it's off...

Expected Results:  
"off"

write the correct form inputs in the page info...
Due to a change in "View Page Info" on FF3 builds, this information is no longer visible. I can see this behaviour in FF 2.0.0.11

In any case, the bug as described is intended behaviour.

A input type of checkbox has a boolean "checked" attribute, which indicates whether the checkbox is selected or not. View Page Info in FF2 does not display the value of this attribute, so using View Page Info, you cannot determine whether a particular checkbox is selected.

The value displayed in the "Current Value" column is taken from the "value" attribute. This attribute specifies a value to pass to the server when the form is submitted, if the checkbox is ticked. The confusion arises because a default value of "on" is used when no value attribute is given. 

For example, use View Page Info on the page http://www.w3schools.com/html/html_forms.asp to see that the vehicle form has values "Bike" "Car" and "Aeroplane".

--
Sam, Carsten: This is my first attempt at triaging an unconfirmed bug. Feedback appreciated. I would mark INVALID.
Graeme, thanks for triaging this bug. I've read through it and you're right! This bug is INVALID. Resolving it as such.

Thanks again! Feel free to CC Carsten and me to other bugs you work on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Version: unspecified → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.