Downloadin Tar Gziped files

VERIFIED DUPLICATE of bug 35956

Status

SeaMonkey
General
P3
major
VERIFIED DUPLICATE of bug 35956
18 years ago
13 years ago

People

(Reporter: uridavid.akavia, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:

User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.13 i686; en-US; m15)

BuildID:    2000041811



While downloading tar gziped files (ending in .tar.gz) mozilla opens the

compression of the file so that in effect it becomes a .tar file. This causes

the file to load more time than it should because it isn't compressed.



Reproducible: Always

Steps to Reproduce:

1.Attempt to download a .tar.gz file

2.Attempt to open it with gzip - you'll fail

3.Attempt to open it with tar directly - success

(2 should succed, 3 should fail)





Expected Results:  Downloaded it with compression so it won't take so long

Comment 1

18 years ago
Could it be that Mozilla gunzips the file after it has been downloaded?

Reporter, could you please try with a more recent build?
Also could you try to download a bzip2 file? (see comments in bug #39241)

Comment 2

18 years ago
The real problem here is bug 35956, "file extension not changed when gzipped 
(.gz) files expanded on download".  Download speed won't change if you do 
something else, although I don't know how many cycles mozilla spends 
decompressing the gzip file.

Comment 3

18 years ago
I absolutly hate having Netscape4/mozilla uncompressing .gz files. This needs to
be turn-off-able, or, preferably, removed.

The main problem is tar.gz files are 99% of the time extracted and uncompressed
at the same time. This leaves the unpacked files, and a compressed copy.
COMPRESSED. As in, not wasting my drive space. This functionality does not
belong in a web browser.

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

18 years ago
this is a duplicate of bug 35956

*** This bug has been marked as a duplicate of 35956 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 6

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.