Password dialog pops up for all occurrences of same site if canceled

RESOLVED DUPLICATE of bug 430567

Status

()

--
minor
RESOLVED DUPLICATE of bug 430567
11 years ago
9 years ago

People

(Reporter: mozilla-bugzilla.20.drkshadow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.7) Gecko/20070920 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.7) Gecko/20070920 Firefox/2.0.0.7

Suppose you're at a site, http://example.com/preview.htm. That site is perfectly viewable to you, but also includes 20 pictures referencing /members/prev/xxx.jpg. 

Assume the /members directory is password protected.

If you go to this site, you'll get a password prompt for the first image. If you enter a correct password, all images are loaded and all is well. However, if you don't know a password and click Cancel, you will then get a password prompt for the second, then the third, then...

On it goes, for each of 20 images. If you're accessing pages behind a members area, close the browser and restart with restoration of the previous session, you will get a password prompt for every page until you enter a valid password.

I find this to be exceedingly annoying. Suggested fix: pop up the password dialog only once for a given domain in some loading queue, or set a timeout for a certain domain unless the refresh button (F5) is clicked.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
I'm going to change the description rather significantly..

If there is a site that has references to multiple password protected items, the password dialog will pop up only once.

If you close a browsing session with 10 tabs open to password protected pages, you will get 10 password dialogs upon starting up, if you cancel each one of them.

It's the latter part that takes a lot of my time when restarting the browser.

Comment 2

11 years ago
I've been affected by this with regard to tabs as well. It's is very frustrating when you're typing in your master password and all of a sudden a new Master Password Dialog (MPD) pops up and takes the focus away. 

Another annoyance with that is that if you enter the master password in one of the dialogs (if multiple master password dialogs open), it doesn't affect the others. You'd think that if you have five that pop up and you enter the password in one, the others would notice that event and either close, or you could click cancel and still have the expected result - auto-fill of uname/password where appropriate. 

That doesn't happen tho - you actually have to enter your password for each and every dialog to get the auto-fill on first load (thereafter, your fine - it's only the first time when the multiple MPDs pop up that it doesn't auto-fill unless you fill in the password for all the dialogs).

Comment 3

10 years ago
+1.  When Firefox is started and several tabs are open which require the same password to be entered a prompt appears for all of them.  Firefox might notice when bringing up the second (and third and so on) request that the first one is already pending.

Comment 4

10 years ago
Agreed.  Firefox is becoming almost unusable in my organization because of this.

When I start up my browser and the 5 - 10 intranet sites try to load, each one requiring the Master Password, I am forced to type it in over and over.  If, out of frustration, I click cancel on a number of the popups, the Cancel / OK buttons on the Master Password dialog become unresponsive and I have to kill the process.

Comment 5

9 years ago
I also get multiple master password dialogs when I open several bookmarks by clicking "Open All in Tabs" on their containing folder, when some of the sites require passwords.

BTW: I guess this bug actually consists of multiple ones:

1. There are multiple password dialogs when one would be sufficient.

2. When the password is correctly entered, the remaining dialogs requesting the same password shouldn't stay open.

3. Aborting some of these dialogs leads to unresponsiveness (if this word exists).

I don't think either of these bugs is minor & I'd rather mod them up.

Comment 6

9 years ago
Heiko: surely solving the first of the three issues you outlined would make the second one moot, and probably also the third?

Comment 7

9 years ago
(In reply to comment #6)
> Heiko: surely solving the first of the three issues you outlined would make the
> second one moot, and probably also the third?

Correct. The second one wouldn't occur at all.

The third one might be an issue in its own right and might also occur in some cases when a single dialog is aborted, or when multiple dialogs prompting for different passwords are aborted, but that's pure speculation. I was only quoting from Alexi's comment anyway.

Another, unrelated issue with the master password dialog is that my PC has two screens, and sometimes when the password dialog pops up, it *looks* as if it has the focus, even though a window on the other screen actually has it. So at least once I happily typed away into the wrong window, almost emailing my master password to a fairly large mailing list. But I guess this is an issue with windows, rather than one of firefox.

Updated

9 years ago
Depends on: 437557

Comment 8

9 years ago
(In reply to comment #5)

> BTW: I guess this bug actually consists of multiple ones:

[...]

I forgot one in my list:

4. If the second dialog pops up while you enter the master password in the first one, it steals the focus while you type. If you simply continue typing, you end up with two half passwords in either dialog. So when you click OK the password store is not unlocked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 430567
You need to log in before you can comment on or make changes to this bug.