If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash if i try to enter the password for the web proxy

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Gabriel, Assigned: Gagan)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; Linux 2.2.12-20 i586)
BuildID:    2000052008

While using a web proxy, witch require autentification, and the browser ask me
for user name and password (for the proxy), the browser crashes when I try to
select the password field with the mouse. 

Reproducible: Always
Steps to Reproduce:
1. Set up Mozilla to use a web proxy witch require authentification
2. Go to a site of your choice.
3. When the browser asks u for a user name and a password(for the proxy) select
the password entering field with the mouse (by clicking on it).

Actual Results:  The browser crashes.

Comment 1

18 years ago
*** Bug 40056 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Adding crash keyword
Keywords: crash

Comment 3

18 years ago
Gabriel -- are you still seeing this with a current build?
Asa -- who could have such a web-proxy with authentification? Networking?
(Reporter)

Comment 4

18 years ago
The bug has now changed behavior. In stead of crushing when I try to
select the password input field, the browser crashes first wen I press
the OK button.

For making the browser crash I do following steps:
1. Set up the browser so that it uses the proxy server (width
authentication).
2. Try to go to a site through the proxy
3. When the password dialog pops up I write the user name and the
password.
4. I press the OK button.

After step 4 the browser freezes for 2 seconds and then it crashes
totally (the main window disappears).
If at step 3 I check the "Remember these values. .... " button, then a
window that tells me that, the values will be remembered, pups up, and
then the browser crashes.

Comment 5

18 years ago
updating component and owner.
Component: Browser-General → Networking

Comment 6

18 years ago
Needs retest. Bug 41404 and bug 41467 have been fixed (2000060508).

Comment 7

18 years ago
really updating default owner this time.
Assignee: asa → gagan
QA Contact: jelwell → tever
(Reporter)

Comment 8

18 years ago
This bug is fixed too. The browser dose not crush any more and surfing to the
proxy (width authentication) works very good. But the way mozilla remembers
passwords for the proxy is a little strange. It seems that mozilla relates the
proxy password to the site you try to visit the first time you use the proxy and
not to the proxy you are surfing through. But I think that this is another bug
and I will make a ny bug report for it soon.

Comment 9

18 years ago
resolving per reporter's comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 10

18 years ago
verified WORKSFORME
Linux 2000070420
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.