[FIX]"ASSERTION: Native anonymous node with wrong binding parent"

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: jruderman, Assigned: bzbarsky)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
assertion, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 284776 [details]
testcase

When I load the testcase and wait a few seconds, I see:

###!!! ASSERTION: Native anonymous node with wrong binding parent: '!aContent->IsNativeAnonymous()', file /Users/jruderman/trunk/mozilla/content/base/src/nsContentUtils.cpp, line 3702

I'm not sure this is a recent regression, but if it is, I suspect bug 378866.

Comment 1

11 years ago
That assertion was just added in Bug 345609.
Well, this is fun.  Spellcheck is getting computed style on a native anonymous node that's already been removed from the document (because the relevant frame is gone).  So the binding parent is null, while IsNativeAnonymous() is true.

I filed bug 399791 on spell-check.  I guess we should make this a warning for now, until that's fixed, but in general, I do think we should be asserting in this situation.
Created attachment 284859 [details] [diff] [review]
"fix" to quiet down the assert
Attachment #284859 - Flags: superreview?(jst)
Attachment #284859 - Flags: review?(jst)
Assignee: nobody → bzbarsky
OS: Mac OS X → All
Hardware: PC → All
Summary: "ASSERTION: Native anonymous node with wrong binding parent" → [FIX]"ASSERTION: Native anonymous node with wrong binding parent"
Comment on attachment 284859 [details] [diff] [review]
"fix" to quiet down the assert

Fun. r+sr+a=jst
Attachment #284859 - Flags: superreview?(jst)
Attachment #284859 - Flags: superreview+
Attachment #284859 - Flags: review?(jst)
Attachment #284859 - Flags: review+
Attachment #284859 - Flags: approval1.9+
Fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

11 years ago
Crashtest checked in.  (I have the testcase run for three seconds.)
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.