If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Exception... "'[JavaScript Error: "gImageView.data[i] has no properties" {file: "chrome://browser/content/pageinfo/pageInfo.js" line: 554}]' when calling method: [nsIDOMNodeFilter::acceptNode]"

RESOLVED FIXED

Status

()

Firefox
Page Info Window
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: reed, Assigned: florian)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Got this exception when I opened the Page Info window today:

Error: uncaught exception: [Exception... "'[JavaScript Error: "gImageView.data[i] has no properties" {file: "chrome://browser/content/pageinfo/pageInfo.js" line: 554}]' when calling method: [nsIDOMNodeFilter::acceptNode]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/pageinfo/pageInfo.js :: doGrab :: line 499"  data: yes]
Flags: blocking-firefox3?
(Assignee)

Comment 1

10 years ago
Do you have some steps to reproduce? The url of the page?
I can't easily reproduce: Reed, can you provide more details on how to see this exception?
Flags: blocking-firefox3?
(Reporter)

Comment 3

10 years ago
I came across this again today. Here's my STR:

1. Visit http://news.bbc.co.uk/2/hi/asia-pacific/7132886.stm
2. Open Page Info dialog
3. See error in error console

Florian, how's that?
(Reporter)

Comment 4

10 years ago
Oh, the error has changed a bit now.

Error: uncaught exception: [Exception... "'[JavaScript Error: "gImageView.data[i] is undefined" {file: "chrome://browser/content/pageinfo/pageInfo.js" line: 556}]' when calling method: [nsIDOMNodeFilter::acceptNode]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/pageinfo/pageInfo.js :: doGrab :: line 501"  data: yes]
mmm, that's an interesting error.
(Assignee)

Comment 6

10 years ago
Apparently we get screwed because |"watch" in { }| returns true.
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 7

10 years ago
Created attachment 292698 [details] [diff] [review]
patch v1
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #292698 - Flags: review?(mano)
(Assignee)

Updated

10 years ago
Attachment #292698 - Flags: review?(db48x)
(Assignee)

Comment 8

10 years ago
This is a regression from bug 201264.
Keywords: regression
Comment on attachment 292698 [details] [diff] [review]
patch v1

r=db48x
Attachment #292698 - Flags: review?(db48x) → review+
Comment on attachment 292698 [details] [diff] [review]
patch v1

r=mano
Attachment #292698 - Flags: review?(mano) → review+
(Reporter)

Comment 11

10 years ago
Comment on attachment 292698 [details] [diff] [review]
patch v1

Fixes a JS exception due to use of JS-reserved word.
Attachment #292698 - Flags: approval1.9?
Comment on attachment 292698 [details] [diff] [review]
patch v1

a=beltzner
Attachment #292698 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 13

10 years ago
Fixed for both Firefox and SeaMonkey.

Checking in browser/base/content/pageinfo/pageInfo.js;
/cvsroot/mozilla/browser/base/content/pageinfo/pageInfo.js,v  <--  pageInfo.js
new revision: 1.11; previous revision: 1.10
done
Checking in suite/browser/pageinfo/pageInfo.js;
/cvsroot/mozilla/suite/browser/pageinfo/pageInfo.js,v  <--  pageInfo.js
new revision: 1.4; previous revision: 1.3
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.