allow tags as message filter match criteria

RESOLVED DUPLICATE of bug 217034

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 217034
11 years ago
8 years ago

People

(Reporter: Michael Soliman., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702
Build Identifier: Version 2.0.0.6 (20070728).

Moin Moin.
As the Message filter cannot Filter Essages by already assigned tags, it is very dificult/tedious to filter messages that have NOT been filtered according to other rules.

Reproducible: Always

Steps to Reproduce:
1.Open Tools/Filter/New
2.Click on the "Subject" Categoryselector.
3.You to not see the Tags.
Actual Results:  
You to not see the Tags.

Expected Results:  
You should be seeing a Selector for Tags.
Tag is saved in X-Mozilla-Keys: header, when local mail folder.
See message source via View/Message Source.
(compact folder may be required to see X-Mozilla-Keys: physically in source)
So, you can already filter with Tag data by;
 1. Add X-Mozilla-Keys via Customize
 2. Filter rule such as "If X-Mozilla-Keys contains Tag-001, ..."

I'm sorry but I don't know whether it works or not during download when next rules(flag like use of tag you are wanting) :
  1. Mail is downloaded
  2. Rule-X : If some conditions, Add Tag-001
  3. Rule-Y defined after Rule-X : If X-Mozilla-Keys contains Tag-001, ...
I don't know when X-Mozilla-Keys: header is physically added while downloading / filtering. But, Tag data is kept in ".msf" at step-2, so I expect step-3 works, I don't know works or not though.
Sorry but I don't know about IMAP case too.
FYI.
Following is advanced search result of :
 Status="---"(open), Summary contains "filter & tag", Changed within 3 months
 (one bug for "Places" is omiited)
> Bug 353036 "Label is None" custom view lists no messages instead of unlabeled/untagged ['No Tag' filter]
> Bug 369745 mail filters which apply tags (keywords) and move messages sometimes lose tags
> Bug 378938 View Filter can cause infinite loop when trying to filter on tags
> Bug 392637 Incoming unread (new) messages which are filtered to add tags or stars cause "new messages" indicators to deceptively persist
> Bug 397009 A filter will let me tag, but not untag
Confirming enhancement request and renaming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: The MEssage filter cannot Filter Essages by already assigned tags. → allow tags as message filter match criteria
And now I have found a bug to dupe this to... (with a patch in process!  hooray!)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 217034
You need to log in before you can comment on or make changes to this bug.