Install XPI extensions from the command line

RESOLVED DUPLICATE of bug 77365

Status

SeaMonkey
Installer
--
enhancement
RESOLVED DUPLICATE of bug 77365
11 years ago
10 years ago

People

(Reporter: Lubomir Rintel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070926 Fedora/2.0.0.6-11.fc8 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070926 Fedora/2.0.0.6-11.fc8 Firefox/2.0.0.6

As far as I know there is no way to install the extensions in an automated way. Due to this no (Linux) distributions I am aware of ship Seamonkey 1.1 with translations (Debian does ship 1.0, there it was possible with some ugly sed magic).

It would be very nice if seamonkey supported "-install-global-extension" command line argument similarly to firefox, or something functionally equivalent.

Reproducible: Always

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 77365

Comment 2

11 years ago
You don't need a specialized tool, just unzip the extension in appdir/extensions/_extension-id_
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> You don't need a specialized tool, just unzip the extension in
> appdir/extensions/_extension-id_

This would work for Firefox.
Would it also work for Seamonkey browser?

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: general
You need to log in before you can comment on or make changes to this bug.