Closed Bug 399962 Opened 13 years ago Closed 13 years ago

Copy sometimes disabled

Categories

(Toolkit Graveyard :: Error Console, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 366479

People

(Reporter: richard.wiseman, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Right-clicking on errors or information in the Error Console sometimes shows Copy greyed out.  Sometimes, at some point later on, it becomes active again.

This appears to be to do with the order in which types of message (errors, warnings, info) occur.  If an evaluation is done by hand in the console before it displays any other messages, Copy is disabled; if this is done after it displays other messages, Copy is enabled.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox afresh.
2. Open the error console.
3. Evaluate something simple like escape("&").
4. Right-click the info that appears: Copy is greyed out.
Actual Results:  
The Copy option is disabled.

Expected Results:  
The Copy option should be enabled.

If the evaluation (step 3 above) is not the first thing you do, but instead is done after (for example) visiting a website that produces an error, Copy is not disabled.
This is fixed on trunk by Bug 366479
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366479
The referenced bug doesn't sound like quite the same problem to me: for one thing I'm using Windows XP.

Either way, I'm not at all clear what the fix is that I'm supposed to use!  I see there's a patch file there, but (a) I haven't got the 'patch' command and (b) the files referenced in the patch don't seem to exist in my Firefox installation.

Any suggestions, please...?
This bug is fixed on the firefox trunk (Firefox 3.0alpha). You could file another bug asking for this patch to be backported to Firefox 2.0.0.x citing this bug. However only security and stability fixes are likely to be approved for updates to the 2.0.0.x series.
Duplicate of this bug: 404350
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.