"LTR" Block elements in an "RTL" page align to the left unlike other browsers

RESOLVED DUPLICATE of bug 328181

Status

()

RESOLVED DUPLICATE of bug 328181
11 years ago
5 years ago

People

(Reporter: php.ajax, Unassigned)

Tracking

({rtl})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

When I set a page to be RTL in the <html dir="rtl"> tag, and I put any block element with <p dir="ltr" style="width:50%"> they align to the left, even though all other browsers (Opera, IE6 & 7, and Safari) show them where they should be, aligned to the right.

I've included a source code for this bug to see it in action and compare other browsers' behavior.

Kind regards,


Reproducible: Always

Steps to Reproduce:
1. Save the attached source code in any file.html.
2. Open it and compare behavior in all other browsers.
3. Hope you fix it :)
Actual Results:  
The whole block element is aligned to the left.

Expected Results:  
It should have stayed aligned to the right in an RTL page.

Test case, please save it and view it:
------------------------------------------------------------------------------
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="rtl" xml:lang="ar" lang="ar">
<head>

<title>Firefox direction bug</title>
<style>

h1,p {
 	width: 50%;
	border: 1px solid #000000;
	direction: ltr;
}

</style>
</head>
<body>

<h1>Test</h1>
<p>This is a test paragraph.</p>

</body>

</html>
(Reporter)

Comment 1

11 years ago
Created attachment 285069 [details]
RTL bug test case

This is a test case of the same bug and the same source, just for lazy people :p
This is fixed in trunk, so I assume it's a dupe. Uri, I think this might have been one of yours. Do you remember the original bug?
Whiteboard: DUPEME
(Reporter)

Comment 3

11 years ago
I have just downloaded the nightly build of mozilla firefox 2.0.0.8
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

And the problem still there, even though the problem is fixed on Firefox 3.0a (renders correctly), but I was hoping to get this fixed in the upcoming release because this seems to be very important rendering issue for BiDi users.

Regards,
(In reply to comment #2)
> This is fixed in trunk, so I assume it's a dupe. Uri, I think this might have
> been one of yours. Do you remember the original bug?
> 
Yes, bug 328181.

(In reply to comment #3)

This will be fixed in Firefox 3.0. It will not be fixed in any 2.0 release, because it's not a security or stability issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 328181

Comment 5

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

11 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.