Move or copy File a bug from QA to Help menu

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
11 years ago
9 years ago

People

(Reporter: jgamleus, Assigned: neil)

Tracking

Bug Flags:
wanted-seamonkey2.0 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4

An entry Leave feedback and suggestions is missing in the Help menu, like there was in early versions of Netscape. This is what made Netscape wonderful, because in Interne Explorer (6) it takes hours to (not) find the appropriate page (try it!!!). In Seamonkey there is an entry Report broken web site in the Help menu, but this is something else.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
An entry Leave feedback and suggestions in the Help menu could simply direct to http://hendrix.mozilla.org
Version: unspecified → SeaMonkey 1.1 Branch
(Reporter)

Comment 2

11 years ago
http://bugzilla.mozilla.org mentions four entries:

Got a problem?

    * Get help with your mozilla.org product
    * Leave quick feedback
    * Report a broken website
    * Report a bug - latest release only

Two out of these four are already covered in the Help menu of Seamonkey. In fact it would be great if all four could be covered.

Comment 3

11 years ago
(In reply to comment #2)
>     * Report a bug - latest release only

Duplicate of bug 149562.
Assignee: general → neil
Component: General → Help
OS: Windows 98 → All
QA Contact: general → danielwang
Hardware: PC → All
Version: SeaMonkey 1.1 Branch → unspecified
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041601 SeaMonkey/2.0a1pre

I'm confirming this, as the capability is still not present. This doesn't mean it won't get WONTFIXed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [trunk and 1.8 Branch]
Version: unspecified → Trunk
(Reporter)

Comment 5

11 years ago
My remark is a duplicate of bug 149562, that got a WONTFIX in 2002 depending on some QA system work to be done in "the future". But I don't know what a QA system is and I don't see any QA system around now, six years later, that I can use. So, what's the procedure? Where can I repeat my request, at bug 149562 or here? Or should somebody or I mark the bug below as a duplicate? Will it then be closed or something?
QA is an acronym for "Quality Assurance". This very bug/RFE tracking system is an essential part of it; the software (Talkback and Breakpad) which sends stack traces to Mozilla when a user gets a crash, is another. There are also the mozilla.support.<something> newsgroups on the news.mozilla.org server (they are intentionally not mirrored on the Usenet news servers worldwide).

Development versions of SeaMonkey (such as the 2.0a1pre "trunk nightly" builds that I use) include a "Debug & QA UI" extension with "Debug" and "QA" menus; I suppose that "QA -> File a Bug" is what you want (it is not in the Help menu though). I don't know if the decision has been made to include that component in release builds or not (the Sm 2 release is still quite some time in the future), but if it is included your request is satisfied and if it isn't it is WONTFIX by design. In either case I don't think that the Sm 1.1.x menus will see that kind of a change before that version is obsoleted.

This leaves the "Quick Feedback" option. I don't know what to do about that. No doubt Standard8 (which I'm adding to the CC of this bug) will know better than I what to do with this whole bug.
(In reply to comment #6)
> doubt Standard8 (which I'm adding to the CC of this bug) will know better than
> I what to do with this whole bug.
> 
We can probably add it, but QA is more Andrew's area.
QA Contact: danielwang → help
(Reporter)

Comment 8

9 years ago
I am using pre-release versions now of Seamonkey and seeing the QA menu.
Can the File a Bug entry be moved or copied to the Help Menu? (Like in Microsoft IE). Then it is visible for everybody, not only testers.
(Reporter)

Updated

9 years ago
Summary: Leave feedback and suggestions entry missing in Help menu → Move or copy File a bug from QA to Help menu
(Reporter)

Updated

9 years ago
Flags: wanted-seamonkey2.0?

Comment 9

9 years ago
I think the Help menu is the wrong place because "File a bug" is not related to Help, and I'm not sure if the "File bug" entry should be visible to other than testers. After all, it really is about QA and that's what testers do.
(Reporter)

Comment 10

9 years ago
Please forgive me to disagree, but many programs have a Report a bug in the Help menu. I think it is because Mozilla has an extensive bug report system that Report a bug disappeared in the QA menu. As a normal user it took me years to figure out what QA was (normal users don't see it in the menu bar and still want to report bugs) and how to get a Seamonkey version with a QA menu. I think the menu item should be moved or copied to the Help menu as soon as it is not a test-release any more. Why else would Internet Explorer and other programs have this option? It greatly helps to improve the quality of Seamonkey by non-experienced users. Not only by reporting bugs, also by remarks for enhancements.

Comment 11

9 years ago
This doesn't belong in the menus, people can find it in the release notes, which are linked in the help menu, but we never should send normal users to file a bug before they at least have read the "known issues" section of the release notes.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: wanted-seamonkey2.0? → wanted-seamonkey2.0-
Resolution: --- → WONTFIX
Whiteboard: [trunk and 1.8 Branch]
You need to log in before you can comment on or make changes to this bug.